Purchase Prepayment VAT Calculation Type Error


We are having some issues with purchase prepayments. From what I can tell everything is setup correctly, it just won’t let us post the prepayment (we get the below error).


We are in Canada so we don’t have any VAT Bus. or Prod. posting groups. In VAT Posting Setup we have a single entry with both posting groups blank and VAT Calculation Type = Sales Tax. This works properly for everything we have done thus far.

We are trying to do a prepayment on a purchase order but we get the above error. I can’t see anywhere in the system where “Normal VAT” is selected. I’ve checked all posting groups, vendor cards, currencies, etc. I don’t see it anywhere. So why is it trying to use “Normal VAT”? Could it be linked to the currency? This is the first order we have processed in Euros so maybe that has something to do with it?

The help documents for the Purchase Line Table indicate that there should be a “Tax Calculation Type” field where we can select the calculation type (Normal VAT, …, Sales Tax), just like we have done for the VAT posting setup. But I can’t see that field (which I suspect is because we have the Canada localized version).

So, anyone have any ideas?


Have you uploaded any HF’s related to localization.

HF’s? Is that short for Hot Fix? We have only installed one hotfix since we implemented NAV 2013, 7.0.34194. Details on what it includes are here: http://nav.dk/content/januar-2013-platform-hotfixes-microsoft-dynamics-nav-2013 I’m not sure if any of that relates to localization …


Okay I discovered some more information that may be helpful (or not). Going into the statistics for this purchase order shows that there is 1 VAT line for the prepayment and 0 VAT lines for all the other sections (General, Invoicing, Shipping, etc). Screenshot below. If I click on the ‘1’ it opens up a dialog titled “Sales Tax Lines Subform Dyn” and there are ZERO entries shown here. So it’s weird that it says there should be 1 entry, but then doesn’t show any? Screenshot of this below as well.

Statistics for Purchase Order

Sales Tax Lines Subform Dyn
3201.Sales Tax Lines Subform Dyn.png

Alright, here’s another update. For this particular purchase order we are trying to do 100% prepayment. We paid up-front for the product and it will be delivered in a few weeks. Originally I figured we would be able to just invoice the order (since it was 100% prepayment) before receiving it, but NAV doesn’t let you do that (I get a “There is nothing to post” message when posting the invoice).

BUT, I have now discovered that if I set a pre-payment of anything but 100% (99%, 50%, etc) it WORKS! There is just something funny about the 100% pre-payment.

Any ideas what differs between a 100% prepayment and a partial pre-payment? Is it trying to do something extra since it’s 100%? Could it have to do with unrealized/realized VAT? We have NOT checked the Prepayment Unrealized VAT box in General Ledger Setup.


Well, time for another update. We just tried to do our first sales prepayment (i.e. a customer prepaying an order they have placed) and we get the exact same error message. This time the prepayment is only 30% and it still gives the same error. I can’t for the life of me figure out why this is happening. It just doesn’t make sense. All of our Sales Tax is setup properly. There no references to ‘Normal VAT’ tax calculation ANYWHERE. Yet whenever doing a prepayment it thinks it’s trying to do VAT and errors out.

Any ideas?


I can tell you that I am getting the exact same error message when trying to do a sales prepayment of 30%. I have gone and changed all the ‘VAT Calculation Type’ associations in the VAT Posting Setup table to ‘Sales Tax’ - and I still get the error message.


Hi Alan,

I’m glad it’s not just me that’s having this problem. I suppose it could be a bug in 2013 then? Seems like a pretty big thing to not work properly though. I only have the one entry in VAT Posting Setup and it’s set to Sales Tax. I don’t see anywhere else in the system to even choose Normal VAT/Sales Tax so I have no idea why this is happening. Maybe now that there are 2 of us with the problem someone else will chime in.


Very frustrating indeed! I’ve been all over the internet as well trying to search for any other post with this error message, but to no avail. If this was a bug in 2013, you would think that the issue would have come to light before this. Do you know the best way to submit this question directly to Microsoft?

No, unfortunately I don’t think there is a way for end-users to communicate directly with Microsoft. You are supposed to go through your Microsoft Partner who in turn would diagnose your problem and if it is a bug then they would file it with Microsoft.

well…I’ve recently become a Microsoft partner, so let me see what I can do!

Haha, well then, yes you should be able to do it somehow. Probably through the PartnerSource portal?

That was almost too easy! I found a whitepaper on PartnerSource which seems to contain information specifically about this issue. If you want to give me your email address, I can send it to you.

I have encountered same error while posting Sales Order Prepayment Invoice for 100% . Client is running the 2013 NA version. Where can I find the whitepaper? (I’m really hoping it’s as easy as you suggest)

Can anyone post a link to the whitepaper or more information on this, I am having the same issue.

Here’s the whitepaper that Alan sent me: http://1drv.ms/1ooDSZW

Also worth mentioning is what I did to eventually solve my problem. My MS Partner discovered that by simply setting the Prepayment % back to 0, clicking YES when prompted to update the lines, and then setting the Prepayment % back to the desired amount (clicking YES again to update lines) the problem disappeared … so who knows what was actually causing it.

Hi Dwyatt! Do you still have the white paper link? Believe it or not, this is still an issue!



P.S. your remove the % and re-add worked for me!