Purchase Order Report

Hello Friends,

When we create Purchase order (Accounts Payable =>Purchase Order Detail =>Posting =>Purchase Order)

when we print the PO , Price Discount and Total amount are not displayed on Purchase Order Report.

Please help me How to display on these fields on Report



Just go the Report, PurchPurchaseOrder,

Open the form design and check whether the fields are there. if fields are present, check the position of the fields whether they are overlapping also check the properties whether visible is yes. If it was overlapping, give the current position i.e “LEFT” , “HEIGHT” , “TOP”, “WIDTH” …

Thanks and Regards,


Hi EnriqueKevin,

In Report, all fields properties are same like Quantity,Unit,Deliverydate,Price Discount,total.

On report Qty,unit,delivery Date are displayed but Price,discount and Total are not display .

Please help me…


Take a back up of that report. Duplicate that report. in Duplicated report, delet the fields which are not displaying and again add the fields which u want from the datasource…in menuitem button, change the duplicated report name… In PO form, inquiries, run the PO report and check whether the fields are displaying…

Thanks and Regards,

Enrique Kevin

Hi Darshana,

go to accounts payable - setup - parameters

and set "Purchase order prices / amount = Yes

Best regards


This setting is also on each vendor and I believe copied to the order.

Hi Darshana,

Those fields are invisibled at runtime based on the criteria.

go to “PurchPurchaseOrder” Report and see the method “enableAmountControls()”

comment all tose lines then allfields will be displayed on Report.

Thanks and Regards,

Britto John Baskar.A

Hi Darshana

Did you find solution for this issue because i’ve the same issue i’ve 2 companies one is working fine and the other one have the same problem

Hi Darshana,

can u send the xpo of this one because i am not under stand how to create ssrs report of purchase order in ax 2012 .

thanks for u r post … it is help me lot …this is the best solution … I tried so many ways but I tried this it came …thanks one agian

AP >> Vendors >> Vendor details form >> Purchase order defaults >> Purchase order prices / amount - Check box to Yes