Problems with exported labels in AX 2009


My problem is we’re a AX partner who made a recent development and we already installed it at a customer and everything works fine. We are now trying to deploy it in a different customer and everything goes ok until you disconnect your AX session. When you go out and in again, the labels are gone, showing no descriptions.

The first customer which works fine, haz X++ license code available, and the second doesn’t and that’s about the only difference these 2 customers have. I even created a new instance in the second customer server to test with the first customer licenses and it worked fine!! and I don’t know if I’m wrong or not, not having the X++ license in the customer shouldn’t be a problem 'cause the only one needing to have a development license (X++) should be the partner, right?

Can anyone please help me with this?



Do you import the labels physically or by the Import tool?
For me its so much easier importing them physically to avoid and label redundacy

let’s say your label file Id is SST

if you installed the application files on C:
then go to C:\Program Files\Microsoft Dynamics AX\50\Application\Appl

you will find all the instances there Open your instance and search for “axSSTen-us.ald” open it with the notepad but note (REMOVE THE CHECK Always use the select file to open this kind of program) and see if is it the right label file

you can copy label files from to anywhere by moving them physically, if its chached or somthing just delete all the axSST that ends with .ali and .alc extension and copy the .ald files again.

I was using the Import Tool and yes, decided to go by importing them physically and it worked. Important thing is you always need to turn off/on the AOS to make it work.

Thanks :slight_smile: