Problem with Navision 3.7 on Win2k Terminal Server

We updated from 2.0 to 3.7. Now we have the problem that when a user with Administration rights uses the online help (F1). The system (win2k terminal server) starts the Windows installer. When i give him the wanted Navision CD, the install process seems to go on. After a while the online help starts. But the next time is the same problem. If i press the abort button, the online help will still be there. When “normal” users press the help button, they see the online help, but i get 2 entries in the event log, that something is missing. Is anyone out there with 3.7 running on Win2k Terminal Server (as client - the DB-server is on an WinNT-Server) I installed 3.7 on my XP laptop. There i saw a similar problem, which could only be solved when inserting during the first start of Navision the install CD. Our Navision Solution Center told me that they have also a lot of problems with the 3.7 binary. But they have no solution. Thanks, Michael

According to my own tech guy, then he told me that you have to install it in the right way for Terminal Server, and that’s NOT with Navsion CD!!! You have to get a program called INSTALL_TS.CMD (or BAT) from your Solution Center. It’s available from Microsoft Business Solutions. And yes there has been many errors in the 3.70 exec. code. When you install it again, get the version released as HOTFIX 12 or 13. It contains a complete new install also.

Part of the new installation program for Hotfix 12 is to fix this stuff with TS, removing the need for this nasty batch file install.

Thanks. I will ask our NSC for the hotfix. I hope this hotfix will only replace the navision binaries and not the objects within the database (which i do not want to replace, as we have changed many forms, tables, reports).

Erik, have you created some sort of user based access to the search tool on Nolug? I only ask, since there are literally hundreds of posts on this topic, so I am guessing that most users, or at least new users don’t get access to search?

Hello, I’ve also installed Navision 3.70 on a W2K TS/Citrix server which is working fine for one user. When I try to connect with a simultaneous user the Navision won’t start and hangs with the Navision bitmap. with filemon from sysinternals I’ve noticed that the system can’t find the file FIN.HMT in the local temp dir in the user profile. The Navision database is on a W2K3 server and we start finsql.exe version 3.70.14555. When I creata a second copy of the Client folder I can start finsql from there without any problem togheter with the finsql from the original dir. I have the feeling that one or more files are not TS/Citrix aware. Is it also normal that the system can’t find the file FIN.CFG in the client directory ? Does someone has any idea [?] Tnx for the feedback. Chris [8D]

Hi dz58gm, I had the same problem with TS on W2K. I solved it by making an own navision client for each user. You don’t need to install this, you nedd only to copy the folder. BUT I only had 25 users and it was made in a few minutes

So not multi user aware [V] I know the soluition you have implemented. I’ve tested it also. So that what I’m going to do also. [V] Does someone knows if MS fixed this problem ? Kind regards, Chris

Hi Chris, we hade the same problem, but in an Citrix enviroment. Hotfix 12 (Version of both finsql.exe and fin.exe) solved our problem. Are you sure you have the latest hotfix to 3.70 ? Regards Daniel

We are running finsql.exe version 3.70.14555. Tnx for your feedback. Do you have any idea were I can find this hotfix ? I will contact my supplier Chris

We got it from our NSC for our Swedish version. So try at your local NSC, they should have this. Regards Daniel

Hello, just to inform you that finsql version fixed our problem !!! [8D] Chris

Clould anyone explain what you did to solve this problem? Did you just replace the fin.exe by the newer version or what? I need to fix the same problem.

Hello! finsql version solved my problem as well! I re-installed the client completely, and I’m not sure if it’s enough to just replace the finsql.exe-file. Thorvaldsione

And regarding the right language-version; I originally installed a norwegian version of After installing an English version og the .14998-version, I just pasted the language-folder from the 14555-installation (in this case the NOR-folder) into the new client-folder for the 14998-version. It works for me! Thorvaldsione


Erik, have you created some sort of user based access to the search tool on Nolug? I only ask, since there are literally hundreds of posts on this topic, so I am guessing that most users, or at least new users don’t get access to search?
Originally posted by David Singleton - 2004 Jan 27 : 22:02:50

[:P][:P][:P] As allways with forums. Search before asking.