Problem with .csv file in XMLport

Hi everyone,

I am trying to import some data from a .csv file into a table I created using an XMLport.
I setup the XMLport as following:

Format : Variable Text
FieldDelimiter : <">
FieldSeparator : <,>
RecordSeparator : <<NewLine>>

When running it, I get the result in the following image.

What shall I do?

Did you try the following settings?

Format : Variable Text
FieldDelimiter : "
FieldSeparator : ,
RecordSeparator : <<NewLine>>

I treid it and I get the following error:

You cannot enter 'Bicyclette' in Decimal.

Sounds like that the second field in your xmlport dataitem is a decimal field (Amount?) and not the Description field.

No, the second field is Description and the fourth field is Unit price

I am using an XMLPort, not a dataport [:)]

Some questions:

  • what version are you on?
  • could you share the import file?
  • running XMLport on RTC?

I figured it out.

Infact, you were correct about the settings but when I tried themit didn’t work since I was using an Excel file with a .csv extention…

Now, I changed my file to a .txt file with the same content, I changed my settings the way you indicated **(except for the third one, it should be not <> )**and it worked

Thank you for your effort :mrgreen:

Don’t use Field separator as comma better use it as TAB.

yeah you’re right…