Problem with a Dataport

I am stumped on a dataport problem here. My datport is delimited by " and separated by a , I have a text file that contains the following lines(along with many others), Line 1 will import without any problem, line 2 returns the error “The length of the source exceeds the size of the destination buffer.” Line 1: “UPSBINNUMBER”,“2989068406”,“S02”,“EA”,“EA”,“Y”," “,“0130020000”,“0500020000”,“0500020000”,“0500020000”,“0130020000”,“0500020000”,“100.00”,” 0.00","",“A2”," 0.00 “,” 0.00 “,” 0.00"," 0.00"," 0.00"," 0.0000"," 0.000"," 0.00","","" Line 2: “0 1176.171ABC12”,“Combination Groover/ChamferingSet, dia. 120mm x 1-1/4’, C.T.Cutters A,B,C,D1 & D2”,“S16”,“EA”,“EA”,“Y”," “,“0130160000”,“0500030000”,“0500030000”,“0500030000”,“0130160000”,“0500030000”,“100.00”,” 15.00",“CA2”,“A3”," 4.00 “,” 0.00 “,” 0.00"," 0.00"," 0.00"," 0.0000"," 338.000"," 0.00",“000100”,"" I am unable to determine the cause of the error. Any ideas?

“Combination Groover/ChamferingSet, dia. 120mm x 1-1/4’, C.T.Cutters A,B,C,D1 & D2” You can not have commas inside the data, the system sees the comma, but not a matching " you need to make the data port fixed width, then you can have the comma within the data stream David

Thanks for the response, David I have changed the FileFormat property of the dataport to Fixed and I am still getting the same error. In the table I am attempting to import into, all my fields are of type Code. Could this be part of the problem?

You can also use as field delimitter. But remember it must be written in the property as shown here. Steen

Hi You could copy or resave the text file as type “Text (MS-DOS)” this is the TAB delimited. Then use these property settings in your dataport FieldStartDelimeter FieldEndDelimiter FieldSeperator Remember to keep the sharp brackets and type in the words as above.

I usally use : FieldStartDelimeter @@ FieldEndDelimiter @@ FieldSeperator ;; and had no problems with import/export. The advantage is that there is no normally text with this signs in line