problem to create DB User

Hi,

How can i create a database user in Classic with SQL. When i’m trying to create a db user its throwing an error like "The microsoft dynamics nav classic and SQL server security systems have not been succesfully synchronized. The Sql server login ****** does not exist on the ********server".

I tried to synchronize like this…in NAV Tool----->Security----->synchronize all logins…

but its not working.

Please help me to find a solution on this

Delete the user ID (Tools>> Security >> Database/ windows log-in) which is creating problem and synchronise again.

What is your security model (you can check File>> Database>> Alter >> In one of the tab)? Is it Enhanced/ Simple?

The user for creating new users and synchronizing have db_owner permissions (like sa SQL server admin) ?

Swith to “standard security model” and try again.

Yeah i deleted all the existing users[windows&database] and tried to create a new db user.then also its throwing the same error. the security model is enhanced.

  1. Make sure that your SQL Server supports mixed authentication mode

  2. Create a SQL LOGIN using the SQL Managament Studio

  3. Now create the DB User in Navision, assign the roles for the user and synchronize the logins from within Navision

how can i check my sql server support mixed authentication mode? and should i need to install sql management studio separately?

  1. Which version of SQL are you using?

  2. SQL Server Management Studio, might already be there, if it is SQL2000, then it is called SQL Enterprise Manager.

  3. Open SQL Server Management Studion, right click on Instance name and then Properties >> Security (4th Page) and check if it is

a. Windows Authentication or

b. SQL Server & Windows

but i’m using sql server 2005

Are you saying that you don’t have SQL Server Management studio installed?

Did you check in Start >> All Programs>>Microsoft SQL Server 2005?

Are you having SQL Express?

but i didn’t install sql server 2005 separately…i’m having an sql server 2005 which comes with nav installation files. in that i’m having only three option.

1.sql server configuration manager

2.sql server surface area configuration

3.sql server error and usage reporting

What edition are u using?

Check in:

%ProgramFiles%\Microsoft SQL Server\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE

Look for sqlwb.exe

No. there is no such file in that folder

What edition of SQL Server 2005 are you using??

Is your installation on a server or on your workstation??

I think you have SQL Express installed, which comes as a part of NAV DVD/CD and that is limited features.

I suggest you install full Enterprise/ Standard edition of SQL.

the sql server 2005 which i’m having in my system came when i did the demo installation, and its not running on a server.

yeah presently i’m having sql express which comes with nav. so i need to install full sql edition.

Get your hands on the developers edition of SQL 2005 and use that instead.

Hi,

I installed SQL Server management studio express. and created a login and a user for the Demo Database. Then i created the same user name in classic with sql server and then synchronize all logins. But when i try login to classic its throwing an error like

"The following SQl server error or errors occured.

18452,“28000”,[Microsoft][ODBC Sql Server Driver][Sql Server]login failed for user ******.The user is not associated with a trusted a sql server connection."

after this i’m unable to login using the windows authentication also. Please help me solve this problems…

Make your authentication mode as Mixed.

Change the Authentication Mode of the SQL server from “Windows Authentication Mode (Windows Authentication)”
to “Mixed Mode (Windows Authentication and SQL Server Authentication)”.

See the following link for more details:
http://support.microsoft.com/kb/555332

Thanks Dhanraj, I tried to change to mixed mode…but i colud see only 2 options which are windows authentication and sql server authentication.