Problem hosting Enterprise portal

I’m trying to host EP for the demo purposes. And here is a problem. The host machine is on my local network , and has a local IP address. I configured my router to forward all port 80 calls to the local IP of the host. So when, from web, I’m calling Http://my external ip/enterpriseportal I do get to the loging page. But once logged in , all the menu’s are pointing to the machine name, instead of using realative path. Does anyone know how to configure axapta to use realative path instead of the machine name in the links? Any help is greatly appriciated. Vlad.

Hi Vlad, Guess the problem is with IIS directory configuration. What happens when you run EP from the host machine itself? Regards, Harish Mohanbabu

Hi Harish, I don’t think it’s IIS. Locally it runs just fine. The problem is , that whenever the app is called from it refferancing the machine name, insteade of realative path. Thanks, Vlad.

Hi Vlad, I guess some problems with webroot/virtual path settings in Web site wizard in EP. I recently configured EP on my web server which is on network and when I run it from other machine, it points to the host server itself and not local machine from which I have opened the web session. All menus work fine(I mean they point to the server address on my webapp is running). Thanks and Regards, Dilip

Hi Vlad, Have you refered to this document titled 'AX-300-TIP-045-v01.00-ENGB ’ yet. This doc in particular deals with deploying Axapta web app in a network environment. All the best, Harish Mohanbabu

Dear Vlad, I got to know your problem and even me too faced the same problem i.e. while logging on to EP with the IP address i.e. http://ipaddress/myep it initially went to login page…but later on when i browsed another pages, it used to take my machine name i.e. http://machinename/myep… Steps to resolve the problem: 1. Go to database. Open the WEBSITETABLE. 2. Make the following changes in the fields value for your website record: TARGETDIRECTORY: \\C$\inetpub\wwwroot\myep SERVERNAME: URL: http:///myep DEVELOPMENTMODE: 1 WEBDEPLOYMENT: 0 3.After making these changes, Clear your cache pages and history. 4.Then try viewing the site. Hope this works for you. Please let me know about the same. I think this is a bug in EP and Axapta gurus should come up with some fix. Thanks and Regards, Dilip

Thanks Dilip, you are DA MAN!!! Vlad.

Hi Vlad, Good to know that your problem is resolved. By the way, In SP3, one more way without fiddling the database is using web site wizard (choose the default option) register the server, wherein server name, one should put the ip address and finish setup. It doesn’t display any error but, one more bug here is the virtual directory is not registered in IIS…So one has to go and do the manual registration of the website in IIS. Once this is done, you are all set… Thanks and Regards, Dilip