Problem connecting to web service if company name contains () - NAV2013

Hi all,

I am experiencing a strange issue with web services on NAV2013.

Recently i created a web service for one of my clients, and published it as is should.
So far so good.
I tested that is could connect to the WS/Services url on localhost on the server, and told the external developer that he could acces the web service.

However he came back to me and told that he was presented with an error.

So i tested the full url for the actual web service in the company on localhost on the server, and got an error that the service could not be found.
Trying to connect to other company in the same database, where company name does not contain (), works fine on localhost on the server.

I then tested in same build of NAV2013 on an installation on my laptop, and there i have no problem connecting to a web service in a company that has () in its name.

So i guess the cause of this issue is to be found in the environment on the server, and not in the NAV2013 software.

The server is Win2008R2.
My laptop is Win10

Has anyone else experienced this?
And more important, has anyone an idea how i can get past this?
(Without renaming the company of course. :))


// Alexander

Hi Alexander,

Not sure if it works, but have you tried to HTML Encode the company name? “My Company Name A/S (2018)” would become “My+Company+Name+A%2FS+%282018%29”.

Hi Erik,

Thx for the response. I hadn’t tried that but have now, and unfortunately same result.

Result is like this:

<?xml version="1.0"?>

<s:Envelope xmlns:s=“”>
Service “MyCompany (QA)/Codeunit/MyWebService” was not found!">Service]( “MyCompany (QA)/Codeunit/MyWebService” was not found!


As mentioned connecting to MyCompany/Codeunit/MyWebService works like a charm.


Rather embarrassing i found out that the issue was caused by a minor error from my side.
I discovered that i had some case inconsistency in my url, compared with the name of the company in the database.

So no problems with ( and ) in company name, just a rookie mistake from me. :slight_smile:

// Alexander

Hi Alexander,

Happy you solved it, but inconsistencies? Like to know what kind of inconsistencies, that could have been? [emoticon:c4563cd7d5574777a71c318021cbbcc8]

Hi Erik,

Just me being unaware.

Didn’t notice an uppercase O in the company name.

So used the url …/MyCompany/…

But the company name was MyCOmpany.

I wrote an app to return the output of /ws/SystemService/Companies and copy/pasted the value to the url. And voila… everything works fine.

Stupid mistake from my side. Since more or less every thread about web services emphasize that they are case sensitive.

// Alexander