Posting dates Credit Memo

We are experiencing an inconsistent posting date error from credit memos created from the copy function. The original posting date from the copied invoice is used as the posting date for the Posted credit memo. This causes problems when it posts to Prior Accounting Periods. Some Posted Credit Memos will get a Posting Date equal to the Work Date. Upon posting the date changes from the copied date to the current date. Note: The user has an Open User Set Up with Allow Posting from is Blank. This is required becauase of the need to Apply Open Customer Ledger Entries that are old. Any suggestions?

What version are you on? When copying documents, there’s a flag for including the header. If you unclick it, the dates on the header will not change.

QUOTE: Some Posted Credit Memos will get a Posting Date equal to the Work Date. Upon posting the date changes from the copied date to the current date. Byron Have you had some changes done by your NSC to the Sales Posting Codeunit to change the Dates for Invoices and Orders? As the “Credit Memo” is the same table you may need a condition added! Navision will not on a “Standard Version” change the Posting Date Unless you are posting a batch of Credit Memo’s and Select to Replace the Posting Date. Copy Document with the “Include Header” option selected, will return the Original Dates of the Invoice, else the existing credit memo date is used, which is Set when raised (WorkDate). As to controlling allowed Posting Dates, you can set then up in two places, firstly in the G/L Setup to Allow Posting From and To, Secondly in the User Setup you can allow Different Users thier own Posting Date Range. Hope this is of Help! Mr David Cox MindSource (UK) Limited Navision Solutions Partner Email: david@mindsource.co.uk Web: www.mindsource.co.uk