Period closed error

Hi, Axapta 3.0 + SP3 I tried to settle an old transaction in Accounts payable for which the period is closed. I used date principle and selected settled date and entered a date from the currently open period. But for some bizarre reason, Axapta is still picking up the original payment date (for which period is closed) and throwing up a ‘period closed’ error message. Subsequently I tried using days’ date and I am still getting the period closed error message. Again Axapta seems to pick up the actual payment date. Has anyone experienced this? Thanks, Harish Mohanbabu

In case anyone has the same problem - Looks like it is a bug. From the open transactions editing form, when you try and change the date principle, for some reason this change doesn’t get reflected. By default Axapta picks up the date of payment. Hence I made some changes to ‘settleTransact’ method in VendTrans table. It works fine now. Harish Mohanbabu

I face same problem. Pls. tell me, How do you change that method?

And same problem here!