Parameter xxxx does not exists on the report

when I open Salespackingslip report, I’m getting error as parameter xxxx does not exists on the report.

I didn’t get any errors while deploying the report.

Pls suggest me , how to solve this problem.

thank you

Are there are changes to the standard report? Does this report worked before?
Please don’t create duplicate threads. I have deleted the duplicate thread for now.

The report worked fn before customizations. I just added a textbox for printing the current date.
after adding the text box , i’m getting the error as parameter location does not exists on this report.

so, I removed that text box , redeployed then also getting the same error.

Are you did Add to AOT after revert back.


Does that parameter existing in contract and you don’t see it in report parameter?
Try restarting the report server service.


yes, it is existed in contract and I can see in report parameter. But before customization, the report worked fine with out any parameter form. The report opened directly with out asking any parameters.

I have restarted the report server services, deployed the report , cleared the caches and also deleted the reports from report server urls . Getting the same error.

How you are opening the report (tell us the path)?


You shouldn’t see any dialog. Try debugging. Add a break point to \Classes\SrsReportRunController\parmShowDialog and see from where the showDialog is parameter is set to true.

I didn’t see any dialog box

The what parameter form you are seeing? You said it was asking for parameters.

I’m telling about the error," th e parameter location does not exist on this report"

Try refreshing the data sources on the report and redeploying it.

I have tried this also, but still getting the above mentioned error.