Opening Entries - Customer Credit Memo - You must specify Adjustment Applies

Hi there

I get the following error when trying to post open credit memo entries into a General Journal:

"You must specify Adjustment Applies-to in Gen. Journal Line "

I don’t have invoice numbers as this is coming from the companies previous system.



Do you have exact cost reversing activated?

Hi there,

No, but thank you I have found the solution. there is a Adjustment Applies field. If I enter a numeric or alph character in the field, it accepts it and does not create a error on the import file. I suppose you have to apply the credit memo to an invoice, but because this is opening entries, I dont have invoices. Do you know if there is a setting in Navision to insist on this field being completed?



just a question and a possible answer to your question. do you really need to effect an opening entry for a credit memo? why not set the opening entries / beginning balances net of any credit memo since the details of arriving at a particular invoice amount net of credit memo is already present in the old program/system ;o) just wondering.

good day.

You do not need to apply a credit memo to an invoice, there is nothing wrong with an open credit on account. There is something else wrong in what you are doing, and without discovering what it is and putting incorrect entries in a field you are not using then this can only cause you issues later.

Ok but then I dont know what is wrong?

Hi Morris,

Thanks for your advise… but my customer wants to bring in all the credit memo’s and dont want to offset it against the invoices…



Are you bringing in these transactions using a general journal? If yes, leave the document type blank (i.e. don’t select Cr/Adj Note). It won’t ask you for an application. We had the same problem.

Hi Sue,

Thanks I have tried it and it works. Do you know if there is a setting to determine that you have to apply an invoice to a credit memo? I ask the question because if I enter the journal manually and not through a dataport, I also get the same message for all credit memo’s. This is a existing customer who is adding a new company and I am not sure if this is standard functionality or customized functionality. The customers development has been done by another reseller so not sure if it is development.




There is a setting in the Local functionalities tab of the General Ledger setup screen. The field is called ‘Adjustment Mandatory’ . Untick this field and you will no longer get the error message. However, as this is part of the localisation for a specific country, the field name and where is it is setup may differ.



GREAT Margie! Thanks so much for letting me know at least now know where it comes from. I will remove the setting for the import and then switch it on again as they would most probably like to control this in future.

Kind regards,