Need desesperate help for "Error 1355 in module 19

I’m so confused with this error, because Navision, first said that is a network hardware problem, than I saw in the forum that people speaks about Hotfixes 7 or 9. ¡¡¡¡ I ask!!! ¿¿Did anyone fixed this problem, please.?? I don’t need theory because I red all that the other guys wrote in the forum, I had spoken with Navision, and nothing is working. Escenario: Old situation: Attain 3.10 with Hotfixes, 30 NavClients in LAN 30 NAvClients in Terminal Server. I made the NetTest and I replaced 3-4NICs with some problems. Actual situation: Attain3.60 Clients and Server no hotfixes (I don’t know which of them because it’s crazy the system thay have for hotfixes publication. The same error … So, any answer?

Hot Fix 9 made it not show up as much but I still do get it once in a while. Mainly when trying to change a price on a credit memo or when I try to filter on dimensions on my G/L balance. It doesn’t happen every time I guess this is why it’s hard to fix. My software provider gave up on the fix after hot fix 9 and sent my database to Navision to try and fix it. So far it’s been 2 months and I haven’t heard a peep from anyone about a fix.

I was talking Ver 3.6 - I also received a new FIN executable dated 11/21/2002. I don’t know if this included the fix or if the fix is separate.

The short description for this error is “DBM not re-entrant”. The most common situation for it is that a function (say f1) in the database layer on the client, is executing a database command (op1) that requires a “server dialog”. This is just a message giving feedback about what is going on - it can be a true dialog box, like that used for creating an index, or a status bar message like that used for counting records. The server (this can be just dbm.dll locally) tells the client that op1 is taking more than 200ms or so and that a server dialog should be thrown up to give the user some feedback. The point about it, though, is that it is created on a separate thread that now enters a windows message loop. Once you’re in this loop, many messages gernated both by windows (in response the painting and the user’s actions) and by Navision internally are read off the queue and processed. Sometimes a message will cause more code to execute on the client (such as doing a record FIND). If this happens, the client database layer is called again with database operation op2 and eventually we get down to function f1 again but on the new thread. Function f1 has already noted that it is currently executing on an original thread, trying to execute database operation op1. However, function f1 is not re-entrant - it cannot be re-executed by a different thread for any reason (the database code is protecting itself from bad callers) - it should never happen and this is the error. The problem is that the UI message processing in Navision should never have picked off messages from the message loop while processing the server dialog that did not belong to the server dialog alone. Unfortunately it does, and the other messages lead to further database operations - and bang. As of 3.70, this error is still possible but should be fixed soon. There was a hotfix for 3.10 that addressed it and reduced it, but did not solve it.

We have this poblem at a customer (10 - 75 /day) and create a sales difered posting. They work with Navision Attain 3.10, clients: Celeron 400, 64 mb ram, and it work very fine. 14 users are posting Sales order and invoices without locks. 150.000 shipment lines per moth Best regards from bcn Salut! Agustí

Hi Agustin Carceller/Robert Cinkaid, How did you come to know about the details of “19-1355 DBM not re-entrant” error details. I am facing problem of “11-100 #Err_Att_Undefined (Module_Att,Err_Allowable(100))” Please explain the remedy for this. Thks in advance. Padmanabh_hv@yahoo.com

What version and circumstances are you getting this for?

Hi Robert Cinkaid, I am facing problem of “11-100 #Err_Att_Undefined (Module_Att,Err_Allowable(100))” in one of the customized reports in 2.6B which on upgrade to 3.1 continues with the same msg. I found it is because of one of the table field property is wrong. But it does not allow me to open the sections to rectify.

Hi Padmanabhan, Have a look into fin.etx in the folder where you have your navision client is been installed. you will get the detail of all the error messages generated by Navision cheers

I faced against your error when I tried to restore a backup file. For mi undestanding it does not depend on the Network. I only worked in mi local machine. My solution was set the DBMS Cache (KB) upto 600000. My workstation wears 768 KB RAM. Note if you modify this default value, your operating system will take the amount of memory you set. So if you don’t have enough RAM memory you will use your hard disk (poor performance) I hope it helps!!!

Update. Our Database was sent to Navision. They finally acknowldged that they could re-create it. They suggested a move from 3.6 executables to 3.6a (US). I still get the error but it’s less then before. Maybe in 3.7 it’s complete fixed?

Hi everybody we also have the error under Attain 3.10 and switch to 3.60 and use Terminal Server with Citrix with the last hotfix 17 - One database with 7 GB 35 - 50 online User - the error came 2 - 10 times a week :frowning:

I had the same error. It was fixed by adding more space to the TEMPPATH destination. Make sure that you have approx. as much free space as the size of your database.

Erik, This error is not actually related to shortage of space in your temppath. You got it because you were about to receive an error about the space shortage, and the UI for that error caused this problem. Your solution will therefore no help others getting it under different circumstances. The reason that this problem occurs in so many situations (your example, scrollbars, running application code, changing control panel settings, …) is that the message processing in Navision (standard win32 GetMessage() loop stuff) has bugs that are causing the database manager (dbm) to be called recursively while dbm is already running a command. This should not happen (dbm does not allow it by giving this error message) but does, unfortunately. It will be fixed very soon for 3.7 and likely also in a hotfix for 3.6 since it has become a far more widespread problem. Note: the SQL version does not suffer from this problem. Do a Search for 1355, member “robertc” to see my fuller description of what is going wrong.

Robert, Thanks. Whereas this might not be the “actual error”, then it DID solve my problem. And this is actually not the first time I had this error with this solution. And if you do a search for 1355 then you’ll see that others have the same solution. I did read your description on the error - but it’s all blabish to me. If I got an error then I don’t need a theoretical explaination (maybe somebody else do) - I need a list of “What to do to solve this error?”. It’s “nice” to know that Navision has this error, but it’s nicer to know how to work-around it - if possible.

OK.

Hi Guys, I think this is a lot like the many “General Protection Fault” errors in 2.00, where many of them were related to printers, to the point where it became easy when a client called with a General Protection Fault just to tell them to reinstall all th printers. ([:(]Remember 2.00[xx(]). then came the service packs, and finally 2.01 ([8D]Hooray for 2.01, the greatest most reliable Navision version ever[8D]). The biggest thing that Navision did to the executable was to make the error messages make sense, so that people could fix the actual error and not try and decode the cryptic message. Remember trying to Adjust Inventory, and it crashed because you had no printer installed. Well I see this as something similar. We see that the actuall issue is that error messages are not reentrant, and cause themselves to crash. So the best fix is to stop waht ever it was that caused the error message thus no message, means no crash. I personally am very thankful to Erik, because I believe that in at least one case I have of this error, that the fix he suggests should work (I know that client is low on disk space) though I know it will not fix all the cases. On the other hand I am even more thankfull to Robert, since I really do need to understand the root cause of the error. So thanks Robert, thanks Erik. … Now lets get back to work[;)].

quote:


and finally 2.01 (Hooray for 2.01, the greatest most reliable Navision version ever).


…until 3.70 of course [:)]

Afternoon all, Sorry reopen this issue, but the reappearance of this thread has come at a very apt time. I am trying to import a large number of objects into a 3.60 database and keep getting this error. I have changed the TEMPPATH to an area of a server that has nearly 60 GB free, and also changed my fin.exe as provided in hotfix 9. I have also looked on this site and the partnerguide site for further info but havent found anything that i havent done already or could easily decipher. Despite this, im still no better off and frustrating is beggining to become a vast understatement [:(!]. Can anyone think of what i can do to rectify this? Maybe i am overlooking something obvious? Any suggestions would be most welcome. Apologies again for dragging this out. Regards John