Navision (any version) filtering bug?

Hi I have just joined and I find this User Group to be very imformative. I have come across a problem in Navision for which I cannot find a workaround. Basically it inolves using the ‘<>’ sign with a filter that contains a wildcard(). Example: I want to filer out Item No’s on a report to exclude Item No.'s starting with the prefix ‘FIN’. If I type: ‘<>FIN-001’, Navision does filter out this item correctly. But if I type: '<>FIN’, Navision returns ALL records, i.e. it will ignore the filter. As far I know, such a filter is completely valid. Why does Navision have a problem with it? David T

Hi David, <>FIN* will work in Navision 3.70 SQL. From ChangesInNAV3.70.doc: P12) Filters Can Include <> with Wildcards Feature When using the * wildcard operator in a filter, it has previously only been possible to find positive matches, for example, all occurrences matching ‘ea’. It is now possible to perform negative matches. For example, to find all occurrences that do not match ea, you write <>‘ea’. The <> wildcard operator can be combined with other filter operators in the normal way, for example, =‘Bear’ | <>‘ea’. This feature has been implemented This feature is only available in the SQL Server Option for Navision. Service System reference: HQ-778-979-CPTB

Thankyou Bjarne Astrup for your speedy response. Now I know that this is confirmed by other developers. David T

Hi To filter this in code see here: To filter this in the application (F7) (without 3.7&SQL): You have to use something like: **<FIN-xxxxx&****>**FIN-yyyyy xxxxx = first number in FIN range yyyyy = last number in FIN range bye André

Thanks André I’ve tried what you suggested in version 2.6 to 3.6 and each time the filter returned nothing. However if you try this: <>FIN-XXXX&<>FIN-YYYY where XXXX is your first number and YYYY is your last number, it will work. It’s not ideal, but it’s better than nothing. David T

Hi David Sorry for misleading you. My filter statement makes no sense with the AND. There should be an OR (|)! Instead of **<FIN-xxxxx&>**FIN-yyyyy please use: **<FIN-xxxxx|>**FIN-yyyyy bye André

Hi André I tried it and it works well. Thanks alot David T