Nav2009 Table Optimisation issue


We recently moved from Nav 3.7 to Nav 2009 on SQL Server 2008 R2. As usual we are optimising the Nav2009 tables from Navision. After finishing the optimisation, none of the users were able to work. The message appeared, denying the table permissions. However it worked when the user is synchronized back again. This is really painful if there are around 100 users on the system. This never happened on Nav3.7 with SQL2000. Is there a way to overcome this issue?



I guess you are using the “Enhanced” Security Model. I highly recommend to use “Standard” security.

With Enhanced you always have to synchronize [N] … not with “Standard” [Y]

In addition to changing your security model, you should also put in place a maintenance plan on SQL Server for rebuilding your indexes weekly and updating your statistics daily. That way you don’t need to optimise your tables from inside the NAV client anymore.

What you should really do is hire someone like Jorg for a day to teach you how to properly set up and maintain your SQL Server database, what to expect from a performance point of view and what you can do about it if that ever happens. SQL Server is not like the Navision database server, you need to maintain it right to get the best performance out of it.

Thanks Jorg

How can i make “Standard” Security. Is there any particular steps to do it. Thanks for your help.



Select File → Database → Alter. Select the Advanced page. Change the Model under the Security heading.

There is a white paper called

Microsoft Business Solutions-Navision:
SQL Server Option

Synchronizing Security in Navision 4.0 SP2

which has step by step precedure to change security.

Thanks a lot guys. It worked.