NAV Automation Server Error

Hi,

I have a problem with the Automation Servers installed on my laptop that is giving me two distinct problems in NAV:

  1. When I try to create a new SQL database, I get the error below.
  2. In an existing database, when I try to create a new Variable in an object of type “Automation” (SQL or Native database) I get the same error (as point 1) when I try to lookup the list of Automation Servers.

The error I am getting is:

Invalid format of GUID string. The correct format of the GUID string is

{CDEF7890-ABCD-0123-1234-567890ABCDEF}

where 0-9, A-F symbolizes hexadecimal digits.

I’ve tried a few things to resolve this issue, but without success.

  1. I’ve tried totally removing NAV2009 SP1 from my machine, rebooting and re-installing.
  2. I’ve tried totally removing NAV2009 SP1 from my machine, rebooting, and installed NAV2009 R2.
  3. I’ve reviewed other software I’ve installed over the past few months to see if it could be one of them (to be honest i don’t know how long the issue has been happening so it’s hard to tell.)
  4. I’ve run a Registry Fix program on my machine to see if it could identify any problems with the registry, but it was fine.

I think what I need to know is where does NAV get it’s list of Automation Servers from on my laptop, to populate the “Automation Server” table (2000000046). It is a Virtual Table so I can’t look directly into it in a NAV client or through SQL. If I try to create a form/table or report to view that table, I get the same error as above!! If I knew where NAV looks for this list (for example the registry), I could go look myself for any strange looking entries.

Any idea’s would be much appreciated!

Thanks,

DID YOU FIND SOLUTION?

Hi, no unfortunately I have not found a solution yet.