NAS - the breakpoint already exists


I have two Navision Application Servers running on the same box. One works fine the second has been temperamental to say the least.

The second one is constantly crashing and putting the error message the breakpoint already exists in the event viewer. The breakpoint it is refering to is part of the code run by the first application server. We have deleted the Navibp.xml file and restarted the appserver and both appservers.

We have tried changing the windows login they use to keep them seperate but even that hasn’t worked. I am wondering if having two application servers on the same server is causing the problem or if there is something I have missed.

I have been trawling through the web trying to find a solution for this but not had any luck.

The Configuration is 4.2 appserver on a 3.6 database.

Anyone got any ideas?



Have you tried stopping the NAS services and running the process from a NAV client directly? That’s how I usually troubleshoot NAS, since you can see the error message pop up, and you can run the debugger.

I have tried that, also created a “substitute” which allows me to run the code through the client as if I were the app server and not been able to recreate it.

It just seems to be the Nas client having the problem.

Only thing I have thought of is moving the code to the bit that start if CGNASSTARTEDINLOOP = false.

I can’t remember the name of the file but Nav creates an XML file for the breakpoint. You might find that if you developed on the same box that NAS is running on and added a break point then NAS is picking it up.

See if you can find it and delete it, then restart NAS.

Search for .XML files on your computer.

Sorry i can’t be more specific but I forgot all the details.


He said he deleted it but I am also starting to think it might have been the wrong file.


I hadn’t had enough caffeine when I replied, and only browse read the question. My bad, should have concentrated.Whoopsies.


The file I am deleting is the NaviBP.xml located in the application data for the logged on user.

The only other thing I can think of is the location I am putting my startup parameter in the NasHandler CU. Does anyone know if the CGNASStartedinLoop boolean has any affect on the way the Appserver runs? I have set it to tru in my code but wonder if this could e causing the problem.


I have seen same problem in NAV 4.0.

You have to stop both NAS Servers before you delete the navibp.xml file. Othervise it will be recreated by the restart of the service.