Mysql Connection

Hello there ! I got following problem and would be grateful if someone could help me : I want to connect Navision to a mysql database, there I wanna connect to one table and transfer some fields to a navision database. So far so got, I found a way to connect to the mysql server but each time I wanna select a specific table I get following error : (Translated from German) The datatyp is not supported by c/side. You have access of one of the following datatypes : (Dieser Datentyp wird von C/SIDE nicht unterstützt. Sie haben Zugriff auf Daten von einem der folgenden Datentypen :slight_smile: VT_VOID,VT_I2,VT_I4,VT_R4,VT_R8,VT_CY,VT_DATE,VT_BSTR,VT_BOOL. I use automation controls : but also tried a ActiveX mysql com object sql : Automation :‘Microsoft ActiveX Data Objects 2.7 Library’.Connection"; sql_recordset : Automation :‘Microsoft ActiveX Data Objects Recordset 2.7 Library’.Recordset"; Any ideas ? Sorry for the huge topic and thx, Christian

HI, As per my experience that error will come when you try to assign text value to a field which data type is CODE in Navision. Kindly assign the text value with Ascii character zero as a prefix to the code field. I had got similar problem while assigning data from VB to a CODE field in Navision.

quote:


Originally posted by Jerry
Hello there ! I want to connect Navision to a mysql database, there I wanna connect to one table and transfer some fields to a navision database. So far so got, I found a way to connect to the mysql server but each time I wanna select a specific table I get following error :


Hi Sounds cool :wink: How did u connect to the mySQL-DB ??? I would like to try that too - could u give me some hints please (how u done it)?!?! Thanks

Hello Rajeshj, thanx for your answer. The Problem appears the instant I try to connect to the table. So I´m not even trying to connect to a field or even assigning a value to a var or a field in Navision. So, in my opinion mysql is giving some value back to Navision right the moment Navision connects. But what could it be and how can I avoid it ? One question, what do you mean with this sentence : “Kindly assign the text value with Ascii character zero as a prefix to the code field.” Don´t get it :wink: Thanx, Christian Ps: Amargosa, ich werde Dir den code an deine e-mail schicken.