Migration to Cloud BC16.4

Dear all,

We have started data migration from BC on-prem to Saas 16.4 using Inteligence Cloud.

Everything went fine except a few tables - Attachment and Sales Header.

The error is:

Error converting data type nvarchar to varbinary.

Does anybody face this error as well and fixed it?
I suspect this is the Blob-fields, but how to migrate them then?

hi… Nazar Sandyga
did you found any solution for this.?.
i am also face this error…

Hi Nazar, have you first upgrade your data into latest version of BC on prem?

if yes have you also find the same error while upgrading the data from SQL. if so then please check into SQL attachment table which field is having the same Datatype which is in error.

then might be you will check the same in VS for on-prem. that’s the point you should get the field and the datatype of that field, if so then you should write the upgrade codeunit and on trigger when you are pushing the data then only you should use the evaluate.

if you are not facing the error on-prem data upgrading, theni think it’s easy to findout why it’s only on SAAS.