Menu Item cannot be dropped on Form design Button group


This is the story - I’ve created a class object (Class1). I’ve dragged and dropped Class1 to Menu Items\Action, so object was created (Class1_menuItem). Now, I dragged and dropped Class1_menuItem to Form1\ActionPane\ButtonGroup, and object was created.

Now, the problem. I renamed Class1 into Class1a, and when I try to open Form1, client crashes. So, I created new class, new menu item, and tried to drag and drop new menu item to Form1\ActionPane\ButtonGroup, but I can’t drop the menu item object there.

Any ideas, how to get over this issue?

You should have updated the menu item after renaming your class.

Now please explain why you can’t drop a menu item there. What happens? Also note that you can add a new menu item button and link it to your menu item.

Thanks Martin.

Apparently there’s an occasional issue in the project tree nodes (suggested to me by other dev) with dragging object from project tree node to destination object in the same project tree node. When I dragged from one AOT to other AOT, it worked flawlessly.

That was just the part of my problem. The main problem was that when I click on that menu item in Workspace, my Client crashes.

That issue was solved by clearing usage data.

Thanks again.

The only problem I’m aware of is that you can’t drag things into an object that isn’t checked out (if you’re using version control).

Oh, sorry for insufficient info,

this was the situation - open Dev Workspace, open Projects, select&open Project1. CheckOut Project1, CheckOut Form1 (part of Project1 tree node).

Try to drag&drop

from: Project1\menu items\Action\MenuItem1

to: Project1\Forms\Form1\Designs\Design\ActionPane\ActionPaneTab\ButtonGroup1 - object doesn’t .

Then, after suggestion from another developer, I tried drag&drop

from: Project1\menu items\Action\MenuItem1

to: AOT\Forms\Form1\Designs\Design\ActionPane\ActionPaneTab\ButtonGroup1 - attempt was success.

I hope this helps to other beginners.