Mantieni Relazioni e Viste in SQL server

Salve! Avete mai provato, nella creazione su sql server di un db navision, a scegliere le opzioni ‘mantieni relazioni’ e ‘mantieni viste’? Beh, anche nella 3.70 IT, non funziona. E pare che sia dovuto ad omonimie fra caption di tabelle/campi. Nessuno in Ialia ha mai trovato una soluzione a questo? Grazie in anticipo. [xx(]

Avevo provato in 2.60 se non ricordo male e andava. Ma la versione era decisamente più semplice, quindi non mi stupisce. Segnalalo al supporto. Marco

quote:


Originally posted by dtruppi
Salve! Avete mai provato, nella creazione su sql server di un db navision, a scegliere le opzioni ‘mantieni relazioni’ e ‘mantieni viste’? Beh, anche nella 3.70 IT, non funziona. E pare che sia dovuto ad omonimie fra caption di tabelle/campi. Nessuno in Ialia ha mai trovato una soluzione a questo? Grazie in anticipo. [xx(]


Ok. Fatto. Appena ho novità posto qui la risposta. Se non ho capito male, questa ozpione in pratica consente di mantenere gli stessi nomi delle tabelle di navision nella struttura sql server, vero? Utile per le query e altre manipolazioni genetiche su sql server.

Chiedo umilmente perdono, ma l’errore è dovuto ad una tabella di una personalizzazione. Il ripristino del backup standard con quelle opzioni attive funziona perfettamente. PErò, e qui c’è il problema vero, speravo in questa maniera di semplificare la vita agli edp delle aziende che estraggono dati da navision con opzione sql server. Mi spiego, nelle viste così create mi aspetttavo che vi fossero alcuni campi calcolati decisivi, tipo Balance sulla tabella Customer, ma così non è. Allora, un EDP che deve farsi le estrazioni ODBC di alcuni valori calcolati, che giro deve fare?!? Bisogna procurare delle viste apposite con i vari campi SUM? Grazie.

Continuo a rispondermi da solo, ma ho trovato un allarmante post: http://www.navision.net/forum/topic.asp?TOPIC_ID=3689

I FlowField non sono visibili su SQL Server se non utilizzando l’interfaccia di Navision. Se vuoi guarda anche qui: http://www.mibuso.com/forum/viewtopic.php?t=2121 Ciao, Marco

quote:


Originally posted by dtruppi
Continuo a rispondermi da solo, ma ho trovato un allarmante post: http://www.navision.net/forum/topic.asp?TOPIC_ID=3689


Ok, grazie per le dritte, ci sto dando un’occhiata. :slight_smile: