Logon delay (Nav 2.6)

The first person to logon every day experiences a delay of several minutes in which the application appears to not be responding. After this delay, the logon screen appears and no one the rest of the day will experience any such delay. We have grown to accept this, but sometimes the delay can extend to 5 minutes or more. Does anyone have an explanation for this and perhaps a way to reduce or eliminate the delay? Thanks.

This is because the server fills up the cache for the first login.

quote:


Originally posted by Lars Westman
This is because the server fills up the cache for the first login.


Is there a way to lessen the time? It seems to be getting worse.

Are you using Database authentication or Windows Authentication? The first is fast. Also, are you using Native database or MS SQL? If you are using Windows Authentication then looking at the system and application logs in Event Viewer should be helpful in both Win2000/XP clients and Windows 2000 Server.

  1. Database authentication. 2. Native database. Have not checked event logs yet. Does not generate any error messages to the client. Again, this only happens for the first sigh-on. After that, all sigh-ons are prompt and uneventful.

quote:


Originally posted by Naji
Are you using Database authentication or Windows Authentication? The first is fast. Also, are you using Native database or MS SQL? If you are using Windows Authentication then looking at the system and application logs in Event Viewer should be helpful in both Win2000/XP clients and Windows 2000 Server.


Hi Al, just to expand on Lars’ comments. Basically when everyone logs off Navision, the server no longer requires RAM for the cache, and so Windows decides to grab it back. Now the server becomes idle. You can see this by going to the server and running TASKMAN (Ctrl+Alt+DEL and select Task Manager) you will see that once everyone logs off, the ram required by the SLAVE program(s) will slowly decrease. The next morning when the first person logs in, the server makes a request to windows for RAM to create its cache. This can take a long time. There are a few things that you can do to make the start up time quicker. Some are “doable”[:)], some are maybe.[:(]

  • Leave a client running all night - [:(] You can launch a Navision client on a Citrix session, and just make sure it is connected before everyone logs out. Remember to log the session out once you get back to work, so you don;t loose the session.
  • Log in from home via Citrix before going to the office - [:)] Similar the solution above, crude, but it works.
  • Reduce the Cache size - [:(] well not a really viable option.
  • Set your Swap file to a fixed size - [:)] My Computer>Right Mouse>Properties> Advanced>Perfromance>Virtual Memory>Select Custom Size, and set Min to the same number as in Max. This will help a lot if your system has problems releasing memory
  • Reboot the server from time to time - [:)] This wont make it faster, but may stop it gettig slower.
  • Reinstall Windows - [:(] generally this helps a lot, but is a dramatic task.
  • Get more RAM - [:)] basically a much cheaper solution than reinstalling windows, but with about the same effect.
  • Remove any software other than NAvision that may be using server resources - [:)] programs such as Arc Serv or Backupexec, any Domain Controllers, Printers, files sharing etc. They should not be on the server, and will only cause problems with the allocation of Resources.
    There is another thing that could be causing the issue, and that is DHCP name service resolution. Try logging into Navision in the morning using the IP address rather than the server Name. If there is a substantial difference, then you could have name resolution or network issues, but that is a less common cause of this issue, than RAM. Hope this helps and let us know how it goes.