Ledger Entry Dimension already exists.


When I try to post the Voucher in “Navision 4”, the system shows the message “Ledger Entry Dimnsion already exists”.

You are requested to provide the solution for the same.

thanks in advance.

Voucher that is a localized feature?

Maybe he is talking about a credit memo?


Would like to add more points for information, as i was facing the error "Ledger Entry Dimension already exists ----Identification field & Values : Table ID=17, Entry no.=‘167450’, Dimension code=‘Branch’. I checked the table- 17(G/L Entry) & found that the last entry no. was ‘167449’, but in the table-355 (Ledger Entry Dimension), the last entry no. was ‘167451’ & due to this users were not able to post any vouchers ( as there were difference of two additional entry no).

Hence in order to solve the problem, I changed these two entries from ‘167450’’ to ‘16745000’ & ‘167451’ to ‘16745100’ in ledger entry dimension table(Table id -355).

Sir, would like to know whether there would be any problem in changing the entry no. in table -355(Ledger Entry Dimension), please be noted that field was editable as I have only a simple liecense (not have any developer license).

I will really appreciate if some one discribe the usage of ‘Ledger entry Dimension table’ (Table id-355)

thanks in advance

NEVER manually change ledger entries. Doing so you may have, with earlier deletions/alterations, caused your problem in the first place. You will run into the same problem again when your entry nos. reach the numbers you changed to.

For the use of the table here is a copy of the online help:

Ledger Entry Dimension Table

When you post an entry using dimensions to a ledger, for example to the general, customer or vendor ledger, the program creates a record of these dimensions in the Ledger Entry Dimension table.

Ledger entries can be created in the following ways: by posting a general journal; by posting a sales order, invoice or credit memo; by posting a purchase order, invoice or credit memo; by posting cash receipts and payments to vendors; by posting finance charge memos and reminders; and by running batch jobs.

You cannot change the contents of the fields in the Ledger Entry Dimension table because the entries have been posted.

So, as it looks like your system is setup to record information for a dimension called ‘Branch’. This is setup in the dimension setup. If you are not familiar with dimensions make sure to get assistance and PLEASE do not change ANY ledger entries manually.


I totally agree with you that not to change/alter any ledger entires but please be noted that I have only an enduser license which have only basic rights to create/modify basic tables like ‘Customer’, ‘Vendor’ etc. as I am able to change the entries in table no.’ -355(Ledger entry Dimension), it shows that the table is of the same category like ‘customer/Vendor’ ,it means that there would not be any problem related to financial part.

But would remember your suggestion "You will run into the same problem again when your entry nos. reach the numbers you changed to". I am trying to contact my channel partner regarding the same.

thanks to all

this might happen if you manually deleted a document or entry without deleting the ledger entry dimensions

Has there been any other resolution of this for anyone else? I ran into this today and have been beating my head ever since. We are trying to invoice a Sales Order and every time it gives the following error.

The Ledger Entry Dimension already exists

Identification Fields and Values;

Table ID=‘17’, Entry No.=‘4280257’, Demension Code=‘DEPARTMENT’

I’ve checked both Table 17 (G/L Entry) and Table 355 (Ledger Entry Dimension) and the last entry for both of those tables was, at the time of my posting this, 4280220. As the Entry No.s in the tables increase, so does the Entry No. in the error. After reading this post I spoke with one of our users here and there were documents that were deleted manually, so what would be the best route to take? Any Ideas? Help…

HOW could a user delete something??

Its only possible if you have SQL base and some “advanced user” who with no restrictions can access SQL database directly. Its a serious flaw in your system if it permits such things - and if its not corrected ASAP, you soon will be in VERY BIG TROUBLE, maybe are already now.

Once more - NEVER manipulate data in NAV tables directly, especially, if you don’t even know WHAT you are doing… Noone will be able to help you afterwards and cure such system!

Its every sysadmins worst nightmare - such an "advanced user", who has somehow found a security breach or workaround and begins doing things he feels to be competent enough to do, but in reality he isnt at all!

I’ve similar error but apply to different table.

I solved it by adding key and it works.

I hope my method works for some one that face the same problem as me.