Labels not showing up in SSRS report


I’ve successfully installed and configured SSRS to develop reports in AX2012. I made some modifications to SalesInvoice, deployed it and the modifications work. However, when I run the report from AX2012 the labels show as Labels!@SYS13864. But when I open the report in Visual Studio in design mode and select “Preview”, the labels do show up! I’ve restarted the AOS several times and did a succesful full CIL compile.

Any ideas?

hey hii jos after deploying am getting one error

i.e. SRSReportView error id 2: Cannot read information from the report server. Is the report manager URL correct?

i have given the url also correct but the same error shows repeatedly

thanks in advance

reply soon

What happens when you open the url in your browser?

I finally found the reason for this. As it turns out, labels are not resolved at run time (which I find confusing, but hey…). To make the labels appear, language-specific versions of a report have to bedeployed to the report server. How that’s done is explained here:

The SSRS Service Account password could be invalid.

  1. From the Start menu, point to All Programs, click the SQL Server folder, click the Configuration Toolsfolder, and then click Reporting Services Configuration Manager.

  2. In Reporting Services Configuration Manager click Connect and then click Service Account.

  3. Set the password and then click Apply. The account and password should be the same as the Microsoft Dynamics AX proxy account. For more information, see Before you install the Reporting Services extensions.

  4. Click the ServerName/MSSQLSERVER and then click Stop. Then click Start to restart the server. Always check with the SQL administrator and make sure no other users are connected to the server before you restart the server.

Please also see for more reference


i want to display one record in one page which is selected as a parameter?