Item name gets disabled after addding second item in sales table form

I am running into a issue in which when I go to the AR → All sales order → Line view , after selecting second item then the first items name gets disabled.

Please help me its very urgent for me.


Is it Item name or Item Id?

Item name is for display, so it will be always in disabled mode.

Item id will not be available for edit after a save.

Product name…

In that when I add second item then first items gets blank…

any modifications to the standard?

No, its only standard.

Hii Kranthi,

I added one field in header part - “Cust Reference date”.

How it is working in case of purchase orders?

Kranthi, I’m a bit confused. As you said “product name” field will be always disabled. But why this thread is still going on?

I mean it’s standard behaviour that product name field will be disabled by default. Not that, it goes disabled only when you create second line in the SO.

Curious for your reply guys.

the value is not shown

oops sorry, I missed reading that statement in the reply. :slight_smile:

Hii Kranthi,

There is same error in purchase.

It uses InventTable\ItemName method, try to debug


I check ItemName method but there is nothing wrong in that method,

Can there is any setup problem?, because I tried export that form to another server, but in that item name shown correctly.


i tried the same … u just have to do is press “Ctrl+ F5” when you opens the form .