Item Ledger No Does not exist


I am working Nav 4.0 Sp3.

When i run the A I C Entries batch Job, I am getting the following error.

that is Item Ledger No " YYY "Does not exist.

What is the problem?

Even i gone through the Item ledger entry tabl;e , but i could not find that entry No.

So how to solve this problem.

Please help me to solve this problem .

Thanks and regards

Was any data modified or deleted on the Item Application Entry table? Did you do any modifications on the costing codeunits? Check whether someone deleted any data from the Item Ledger Entry table?

Someone or some process has deleted teh item ledger entry that now requires adjustment, which would suggest you have a much bigger problem than just correcting an item ledger entry. Is this in a live environment dare I ask?

Hi experts,

Yes that’s true .

That entry was deleted in Item ledger entry and same as Value entry was also deleted for that ledger entry

But Item Application has that entry.

So how to solve this problem .

Experts please throw Your valuable information to solve this problem to Run the A I C E.

Well I have never hacked a system in this manner, and never would, so it is difficult to comment on “how” you would fix something.

I will not ask why you did this, but you obviously need to remove it from every related table and everywhere it is called in the adjust cost entry routine, this means painstakingly pulling apart the data relations for the mess created, you can get little help really, you have the data, you need to sort it.

Oh wow… Looks like this problem will be very ugly. For future reference, never EVER delete ledger entries. Especially one as sensitive as item ledger and value entry. All adjustments should be done in journals or documents.

My suggestion to you is to restore the entries as it was and try running adjust cost process. My fear is that your inventory value may be irreversibly damaged because of this… Should your inventory value be incorrect, you will need to replicate the transactions to see the true total and try to copy the exact contents over to the production ledger entries.

Nonetheless, you’re in a world of hurt… [:(]

Thanks Alex chow,

By the way here i need to tell onething.

OUr AICE batch job is manually.

So daily we had tekn back up for every night.

But after they delete the Ladger entries they had done lot item transactions , sales , purchases, transfers, negtive…

So what is way to to get back that deleted transactionss.

Well assuming you cannot restore a backup bacause of subsequent transactions do a test backup and manually recreate the ILE in the table if you can. A hack in should not be an issue as you hacked it out [:D]

Yep, you need to replicate the transactions for this item on a new database and copy the contents over to the ILE, VE, and G/L while ensuring the entries numbers are the same. Afterwards, you need to test the hell out of it.

I would estimate about 50-100 hours doing this depending on how much transactions you have.

Exactly as Alex posted it, that is his advice.

i) Restore the back up to a separate database

ii) Note the deleted transactions - every field, every value in every table that was deleted

iii) Manually recreate these transactions in a test database, copy of your live.

iv) - m) Test

mi) Apply the manual changes to your live database.

mii) Cross your fingers.

Thanks Alex chow, Steven,

I follow what u suggested.

When I run the A I C E then system Following error

Item Ledger entry “ 2314 doesnot exist .

So I gone to back up take that entry and go back to Live databse enter that entry.

Then again I run A I C E

Then again system show s one error

That is There is no value entry with in the filter

Item ledger entry : 4513 Qty <>0

Again I gone to that entry and inset the value entry for that ledger entry.

Like this system throws 4 errors.

I inser t all the entries what system suggested.

After that I run the batch job .

But batch job is keep running for around 9 hours ………

When I run the batch job

These fields are chaning in that batch job :

Adjustment Level : 27590031Item No : BlankAdjust : applied cost****Cost FW Level : 1

Entry No 12282

After some time Only adjustment Level field is changing but rest of the fields are not changing.

Item No field is blank.

What is the problem .

How to stop that batch job.

What is the wrong ?

Pleazse help me.

It means there are issues with the data, a blank item will screw the routine, who knows what other errors exist when the data has been deleted directly in the tables? Very hard to assist you really, you need to keep trying to correct the errors one by one.

It doesn’t look like you replicated the data appropriately. You have to replicate the data using EXACTLY the documents that created them. So you need to recreate the purchase orders, sales orders, etc in the proper order. You also need to create the DELETED that were deleted.

Most of the case, this is not possible since no one know what was deleted. My best advice to you is to wipe out the item ledger, value entry, item application, and other related tables and positive adjust the beginning inventory. Needless to say, your item history is lost… [:(]

Thanks Mr. Steven , Alexchow,

I deleted that item .
Now the Adjust item cost batch job running smoothly.

I asking one suggestion from .

My client operations are

Daily 20 Purchase orders , 20 Sales orders , 30 Transfer orders ,
5 Prouction orders( Complete), Item journal( Negativeadjustment) to issue material ( 100 transactions).

So what is your valuable suggestions about Automatic cost Posting, Automatic cost Adjustment ?

Should i place always checkmark ?

Or do i need to run batch job manually.

Please suggest me.

I really do not want to ask - you deleted the item?

The automatic cost posting depends on teh business and teh costing method and how often they want the true costs updated. So I would presume automatic cost posting is on, the automatic adjustment is a period and affects average costing calculations so it depends. You will still need to run the batch job, how often depends on teh needs. Each customer can be different!

These tick boxes are not about the number of orders per day. They are related to how the company does business. Only you can know what they do and how they should use these.

Thanks Masters,

since two weeks we did not run AICE, Post inventory cost to G/L.

When it comes to AICEntries batch is running smoothly.

But when i run the post inventory cost to G/L batch job is manually Only two items are posted general ledger .

Rest of the items did not post to General ledger.( In report it is showing only two items , Actaully in report it has to show atleast 200 items)

what is the wrong ?

please suggest me.

Why should it show anything if the costs are already posted to the GL?

I think in any case, the original poster is screwed. By deleting and manipulating the ledger entry and “deleting” transactions, I just don’t see how you can get reliable information out of it anymore. By prolonging the “deleteall and reimplement inventory”, the problem will just keep compounding.