Item Ledger Entry doesnt exist, entry = 0

Hi all,

I am currently facing an error " The Item Ledger Entry Does Not Exist. Identification fields and Values; Entry No=0" from my client. The Purchase order posted received and unable to post invoice.

I have done some testing as below and couldn’t retrieve the error:

  1. No Series in No. Series setting has changed and removed. It doesn’t affect in posting the document.

  2. If posted received in PO and shipped/invoiced in SO. It still can post invoice.

Appreciate if you can direct me on how to check further on this case and solution. Thanks a lot!

Please check the following:

  1. If Purchase Receipt is not reversed.

  2. If Purchase Receipt is not already Invoiced.

  3. If Someone has deleted Item Ledger Entry (This has very less chances but some end users who accidentally got partner license may do this).

Thanks for reply.

  1. If Purchase Receipt is not reversed. - Not reverse

  2. If Purchase Receipt is not already Invoiced. - not invoice

  3. If Someone has deleted Item Ledger Entry (This has very less chances but some end users who accidentally got partner license may do this). - User didn’t delete.

When I copy the database and import into my Nav, it works well for all normal process. Really not sure why once client posted, the item tracking lines will goes disappeared.

There may be several reasons. Including inappropriatenesses (aka:errors) and modifications in standard.

Your Purchase Order has a Posted Purchase Receipt (at least one).
Which contains then received lines.
Each line has field “Item Rcpt. Entry No.” which has the “Item Ledger Entry No.” which is the result of the posting.
What is the value in the lines?

The easiest way thouhg: Are you abel to turn on the debugger, just to locate where the error occurs?