Item has no inventory parameters error

When trying to firm orders from MasterPlanning, I get an error message that says “Item has no inventory parameters”. This only happens when firming orders from MasterPlanning, I can create manual POs on the same items.

Any thoughts what is causing this?



Run the consistency check. My guess is you imported your items and did not populate all system required tables.


I faced the same error and i run consistency check but error still appear,

plz help for urgent.

You have imported the data and not populated all of the required tables. If you search teh forum on item data migration you will get information on the tables you must populate based upon version and requirements. Essentially you have missed one, and I cannot remember the ones, probably the module tables.

i checked the data in the follwoing tables

  1. InventTable 2) InventLocation 3) InventDimGroup 4) InventModelGroup

  2. InventTableModule 6) inventiteminventsetup

and i found the records for items

also i run consistency check and error not resolved .

Check the data throughly, not just that it exists. Also import into the InventItemInventPurchSetup and InventItemInventSalesSetup. You may need to read about the issues others have had - there have been lots of posts about the item import on here.

I was able to resolve this issue by verifying the following:

(1) As posted by another user, make sure that all the items in InventItem table are also in each of the following:

  • InventItemSalesSetUp

  • InventItemPurchSetUp

  • InventItemInventSetUp

(2) in each of the tables above, records can exist multiple times (depending on the number of site specific data you have). One thing to make sure of is that all of the items are in these tables with “AllBlank” in addition to any other location ID.

thanks for ur advice

but i verified that and error still shown [:(].

If you have populated all of the tables with “correct” data and run teh consistency check it will work. So now you have two points to review - your data or your scripts. You have not told AX everything it needs, but with the information provided you have recieved about all the possible advice, you will need to dig deeper yourself.

OK … try this then:

  • Take one of the items that is giving you the problem and manually re-create a test items with the exact same parameters, particularly anything related to site, warehouse, location.

  • Either download the InventItem[…]SetUp tables or look them up in the AOT. Take a look at the Dimension Number of the item you created v.s. the Dimension Number of the item(s) you’re having problems with.

There probably is a discrepancy between the Dimension Number in these items.