Issue encountered dupon installation of KB 3109690 in AX2012 R3 CU9

Hi all,

i installed the hotfix KB 3109690 on my AX2012 R3 CU9 environment. the installation of the hotfix is successful and prompted no conflict. The AX is running after the post installation procedures(software upgrade checklist). But when i try to use the workflow(any active workflow), the workflow cannot be submitted. when i tried to open the workflow configuration, it prompted the following error:

An unexpected error has occurred while opening the workflow. See the event log on the AOS and contact your system administrator to resolve the issue.

i tried the solution posted below but still it isn’t working.:

thanks for the reply


Remove the AUC files and KTI files from the %localappdata% directory

Remove usage data.

if none of this helped. Because this was a CLR exception, I modified the try/catch in the method that was throwing the error to show the inner exception. The method Forms\ was modified so it looked like this:

public void run()
System.Exception interopException;

modelEditorControl.Load(workflowConfiguration, userSettings); // ← error thrown here
[some more std code]
catch (Exception::CLRError)
interopException = CLRInterop::getLastException();
while (!CLRInterop::isNull(interopException.get_InnerException()))
interopException = interopException.get_InnerException();

error(strFmt("%1", CLRInterop::getAnyTypeForObject(interopException.get_Message())));
throw error("@SYS327400");


I found this posibilities:
This is a general error and it could mean a lot of things. Make sure you check the obvious things first:

Make sure that the build number of the client maches the build number of the server
Make sure x++ compilation has been done on the AOT
Make sure CIL is compiled without errors
Do a data dictionary synchronization
Refresh the WCF configuration using the Dynamics AX 2012 Configuration utility
Remove the AUC files and KTI files from the %localappdata% directory
Remove usage data
Well… you know… do the usual.

But apparently, change the method is what works