Info Part not getting invisible in Ax 2012

Hi Pioneers,

Actually I created a new form and created a part for it, but later I set the Visible property for that Part to NO, despite of setting the Property to NO**, the form part is not getting invisible.**


Please refer the following link.

I hope this will help you.

Thanks & Regards,

Raman Kutala.

Hi Raman,

Thanks for your prompt reply…I already referred the above link, but it didn’t work.



Its working for me.

Hello Raman,

When the Part property is set to “NO”, then the respected part should not be visible. But in my notice, it is getting visible in yours case also, as I was experiencing. Please correct me, if I am wrong conceptually. Shall be very grateful to you.


What is the significance of the Part property “Visible” ??? If it is set to No.


Hey Thanks Raman,

Its much good approach…but when we will not select the “PartLocation” property as “PreviewPane”, then in your view should the parts be visible in form ? Because in my analysis, it is not mandatory to select the “PartLocation” property as “PreviewPane”, while one goes for disabling the visibility.

Looking fwd for yours valuable feedback.


The Visible property set as NO the form part will be the below screen**:**

If You Expand the Form Part it will show the record information. But, by default it will invisible because we set the Visible Property as NO :



Hi ,

Thanks a lot for your wonderful explanation…but I have checked the above explanation, by making “Visible” to “Yes” and “No”… I got the same result. For your reference, a PDF file is attached herewith.
Doc1.pdf (152 KB)

Means to say, in both the options “Yes” and “No”, the Part is visible.


Please reply


I gone through your previous posts one simple thing you forgot to do is just compile the form after you set the visible parts property to “NO”

Simple thing you’ve to do is if you do not want to view the Fact box parts say( partname: Part1) set the property Visible to “NO”.

Note: Compile the form, Save the form and restore it.

Now you’ll be not seeing the Part1 in the Factbox.


I am very sorry for delay reply. I was busy with my work.

You just Compile the Form and Restore it. Then every thing will be working fine.

Thanks & Regards,

Raman Kutala.


Clear usage data and see the difference each time changing the property.