Incorrect setup of dimension groups

I’m encountering this error when clicking the drop down of configuration.

We have installed the CU7 on this environment and doesn’t have any customization on it.

Any idea or resolution regarding this matter would be greatly appreciated…

Thanks in Advance!

Schneizer

Do you have any items with configuration set and what are you settings on the screen prior to this - does the dimension set selected on the report contain configuration for example?

Hi Adam,

It occurs on Inventory and Warehouse management > Common > On-hand Inventory. A Query Form will pop-up and when you click the drop down of configuration, this error occurs. The same also happens when adding color, size and style and clicking its drop down.

can you check if it occurs in anyother place as well, and also can you check if Inventdim table is customized or not if yes then export it and delete the customization and then again check it plz

Hi Kunal,

I’ve tried it on another environment, but it doesn’t occur… plus there are no customization in it.

The tested environment was CU6. The error occurs on CU7.

You would need a developer to debug it and tell you the logic of the call of the message

Hi Schneizer,

You can fix this error with the way to change extended data type of field RangeValue in TmpSysQuery to “Range” (defaut is “Str1260”).

Hi,

This is a known issue and should be solved with KB2900947. You can view and download the fix from Lifecycle services:

https://fix.lcs.dynamics.com/Issue/Resolved?kb=2900947&bugId=848221