Incorrect parameter for the function SysDictEnum.value2Index

Hi all,

First of all, I apologise if this is not the correct sub-forum for this question - I am not entirely sure if this qualifies as a technical issue, but it appears so to me.

As the subject line says, I am getting the following error message:-
Incorrect parameter for the function SysDictEnum.value2Index

This happens when I try to get to the Structure designer (General ledger > Setup > Dimensions > Dimension sets > Structure designer).
And this only happens for a specific Dimension set.
Also, this Dimension set only exists in one company (my system is setup with multiple companies).

Please can anyone let me know how to solve this issue?

Many thanks,

Arthur

Dear Arthur,

Have you found the solution I am facing the same situation, when I select the “Element” in the type, nothing appears in the “Topic” field and when I try to save it gives me the same error as in your case “Incorrect parameter for the function SysDictEnum.value2Index”

I would really appreciate your help in this regards,

Thanks,

Tariq

i have the same error

I created a new Dimension Focus and used it in reports, for example, if ACC is not working I created new dimension focus by the name ACC1 and used it in my reports and then it worked. However, I don’t know why this issue comes up.

still not working