ImportData

hai friends

i have a different problem.I have imported data through excel template in my inventTable and all related tables.The import is successful. But when i open the form i can not see my data but if i open the table i can find my records.Could u tell why this is happening.

thanks in advance.

Hi,

Run Consistency check job under Basic > Periodic

Thanks for Replay Harish,

I run Consistency check.here i found small waring to that particular item .i.e

Item parameters for Purchase order do not exist.

Item parameters for Sales order do not exist.

Item warehouse parameters do not exist.

these are all the warnings where i fill these fields in item template.

so please help me to this area…

Hi Kishore,

Which all table you have imported?

Hi,

InventTable,InventTableModule,InventItemLocation.These are the table i taken

Ok… i will suggest you to check the dataareaid also. it should be company’s name.

Hi,

I check in tables the dataareaid is taken to where i import template data.

Hi,

For the ‘InventTableModule’ are you importing 3 records for every item?

Next question is - did you run consistency in check mode? If answer to the first question above was true, then try running this in fix mode and see whether it resolves the issue. To be on the safer side, you may want to take a backup of database before you do this.

Hi,

For ‘InventTableModule’& inventTabel&InventInventItemLocation these are the tables i imported only one record for each table with the same Item number & i filled only mandatory fields.

I run consistencecheck in both fix error and check again i have same problem.i try to another modules i successfully import the data.

Hi,

For ‘InventTableModule’ there must be 3 records for every item - one each for stock, purchase and sales.

From your message, it appears you imported only one record which is incorrect.

Thanks Harish,

It is very helpful for me…