Import product on Data migration framework

Hi,

i have been trying to import a product list via the data migration frame work.

i have done the following:

  1. create the entity name and select product, when i generate the source file it gave me the following fields as mandatory:

DisplayProductNumber

EcoResProductTranslation_LanguageId

EcoResProductTranslation_Name

ItemId

ProductSubType

ProductType

none of the above files can be unselected.

  1. generate the source file, in the source file

  2. generate the source mapping

  3. validate

  4. i go to the staging data, and everything is fine

  5. copy data to target, here comes the problem, when i run the job, it gives me the following error:

Cannot create a record in Product number (EcoResProductIdentifier). Product number: XXXXXXX.

The record already exists.

when the record is totally new, i did change the item name many times but the same error, actually the error is created from the ItemId field, which i cant ignore.

what should i do?

is there any other field that i have to include in my file?

Regards

Fadi ghrawi

Check this recent post

http://www.fourone.se/blog/2012/11/06/dmf-cannot-create-a-record-in-product-number-ecoresproductidentifier/

Hi munib,

Thanks for the reply i think that my problem was generated because i didnt update my AX kernal version to 6.0.1108.670 and i was using the old one.

now everything seems fine after installing the hotfix.

am not really sure though

Regards