Import error excel template

Hi All,

I’m having a real headache trying to import using excel templates. I have the one excel template file that consists of the following tables that need to be imported into AX 2009.

reqitem table

Invenitempurchsetup,

inveniteminventsetup

inventitemsalessetup

invenitemprice

inventable

inventablemodule

inventtxt

inventitemlocation

I have 11,919 records in each table, and selected all the lookup values and after a number of hours I receive the following error:

Error Microsoft Office Excel import\Importing Items from C:\Users\jramage\Desktop\DM1\Items\New Folder\Items (3)\Items.xls The number of arguments provided is different from the number of arguments accepted by the method.
Error Microsoft Office Excel import Data import was interrupted

I’m tearing my hair out please help.

John

Hi John,

Are you getting this error from inside Ax? If yes -

  1. Set breakpoint on ‘Add’ method in ‘Info’ class.
  2. Run the import. Note - don’t run import for all records. Run only for 50 or so.

This way you can clearly understand and identify the issue and fix it. Probably you would require a developer to assist you in this.

Good luck,

Forgot to mention this -

On other note - I have come across cases of import running very slow in Ax 2009. I understand MS provide a fix for this issue. If you haven’t got it already, do please contact local support.

Please note - the fix is only to speed up import process.

i imported data for the table projcategories. i am able to view the data at back end but not on the form. i did consistency check in basic module. even though my problem is not solved

The number of arguments provided is different from the number of arguments accepted by the method.

It says that the number fields in the exported template is different from the number of fields that you are trying to import…

Check whether you have added any fields manually to that format…

Try by importing the two or three records - if there is no problem - it should import all the records - if not check for the field value whether they are ported correctly in the Excel or not…

Generally this will happen when you don’t import some of the required tables. Though the projCategories records are imported into the table but they will not be shown in the form due to the other data sources and the relations between them…Check what are the other data sources available in that form.

Import CategoryTable along with the ProjCategory table(create a template with these two tables and import it)…,

Hi,

sorry for the delay,

actually it got solved on that day itself by importing category table…

thanks for reply.

I am facing one more issue which am not able to solve. In dialog i have added dimension as a field but i need only department… i am in need of syntax how to make visible(0) of purpose and costcentre…

please help me in this

hi,

i got same error when i tried to update data from excel to AX temp table.

may i know how you did solve this issue? what do you mean “importing category table”?

please give me some advise.

thanks.