I can't start up my old database!

Okay, this was dumb on my part, but here goes. I needed to move an old database to a new location on my server. It was a test database, therefore not that important. Well, I forgot to shut the service down before I started moving these 6 files. This resulted in the first file of the database, having a time stamp, different from the other 5 files. Well, copying them back and trying to reactivate the database only resulted in an error. It says that the database is corrupted. I’ve tried changing the times on each file to be identical, but it hasn’t helped. Does anyone else know what I can do to remedy this? I’m positive that there were no changes made to the database while this was in effect.

Unfortunately Navision is not too forgiving in these cases. If it was a production database, you could send it to Navision for recovery using Dart. I guess you have tried a backup? I assume the error is the big screen that says you should try to make a backup first? Is that correct?

Well, luckily, I managed to find a backup that I didn’t know I had. (I had like three copies of the same backup, and since the database wasn’t THAT important, I decided to free up some space by deleting my backups on that server. Well, I had an actual navision backup on another server, and I’ve spent most of the day restoring it. (A very long and tedious project). What is Dart? If it’s capable of recovering a database, why can’t I just get a copy of it? I was also curious as to how difficult it would be to take a hex editor (one that could handle a 2 gig file) and edit the time stamps in each database file. Maybe it’s crazy, but knowing a neat trick like that could save precious hours in an emergency…

Glad you recovered what you needed. Dart is only available to NTRs, so you will have to send the database to them for recovery. On another point, and it is just an educated guess, I don’t think the Date stamps were the real issue. What I would assume happened, is that whilst copying the Database files, the database was modified. Thus the version management would have shown that the versions on each part of the database were not the same. In this case, and if there is sufficient free space, there is a good chance that DART would have worked.

Well, that’s possible, but here’s something else to think about. When I checked the windows time stamps for each database file, only the first one had a different date. The last five were identical. I’m not sure what goes on under the surface of Navision, but I know that nothing was accessing the database. I didn’t even have a client open, the service was the only thing running. NTRs only huh? Surely it’s hidden on the net SOMEWHERE to…demo :wink: maybe?

What actually happened is that the path to the additional 5 files is held in the first fdb. When you moved the first one, it was still looking to the old path for the other fdb files. The solution is to move the files then open the database using the command line arguments for FIN.EXE. That way you can repoint the links for the additional files. Chris Krantz NCSD,NCSQL,MCSD,MCSE Microforum Inc. Toronto, Ontario, Canada

You mean you can specify that on the command line?! That would have saved me SO much trouble! However, I don’t believe that was my problem, because I copied them back into the exact same location as they were before. Remember, the error I was getting talked about an invalid time stamp. But about the commandline arguments for FIN.EXE, where can I find those? Maybe running it with fin.exe /? (I should probably try that first, duh) Thanks!

database=c:\dbfile1.fdb+c:\dbfile2.fdb and so on is the correct syntax if i remember correctly. //Lars

You all ROCK! Thanks a lot.

I believe the time and date stamp message are misleading. When you tried to open the database in its new location, I think Navision opens the first section of the database, updates the time and date stamp, then tries to follow the default embedded path to the next section, can’t find it and bails out with the time stamp error message, assuming (incorrectly) that you have done a partial restore (or something like that). Explicitly defining all the database segments into the command line as previously suggested is the right answer. Be careful about the placement and naming of your directories because there is a strict limit on the total command line length. I ended up putting all my database segments into the root directory and naming them A.fdb, B.fdb, C.fdb, etc. in order to fit within the command line length restriction. Dave Studebaker das@libertyforever

Okay guys, I tried it, and I’m still unable to open up the database. It’s giving me that same error. It took awhile to finally get it to even start navision due to the text limitations of the command window and Navision. After renaming the files and throwing them in my root directory, I tried running it with the following command line arguments: fin.exe database=e:\a.fdb+e:\b.fdb+e:\c.fdb+e:\d.fdb+e:\e.fdb+e:\f.fdb (It was all on the same line) It’s giving me that same time stamp error that it was before. Is this the correct syntax? Surely there’s a FORCE option or something like that, right? Thanks for all the help so far, you’re all a very big help. (Anyone know where I can get a list of ALL the commandline arguments for fin.exe?)

Hi Michael, as I said, this error is because Navision thinks the database is corrupt, not because it can not find the remaining parts of the database. What Chris was saying was something unrelated. Try creating a database with two parts, then disconnect, delete the second part and reconnect, then you will see the error message for a missing database part. Unfortunately as I said earlier, the error is that Navision thinks that the most current version is corrupt, and you can not fix that. By the way, the event that woulod have caused this error, would be a Navision CLIENT accessing the server somewhere between the coping of the first and last database parts. In any case Navision do not recommend copying the database as a method of backup. If you must, then make sure that the service is stopped. I have seen many problems with backups being made at night, when absolutely no one could be logged in. Anyway becarefull of this.

I think Chris was right. What actually might have happened is that the client opened the first part from the backud up directory and tried to open the others from the path specified in a special section of the first file. Starting the server instead of fin with the database argument including the new pathes might solve your problem. Thus the server’s commandline might look like: server database=part1+part2+…partn

Well, I tried using the server.exe commandline arguments, but it won’t accept the + symbol. Is there any other way I can specify multiple database files?

I’ll let you decide whether the date/time stamp can be fixed by reconnecting the files. There is a bug (?) in 2.60 which doesn’t allow you to specify multiple files. From Navision Partner site: ***** NOTE: The 2.60 (B, C, D or E) client cannot be used to open a mutlifile database using the method described above. This is fixed with the next release. ***** The best work-around is to open the databases with a 2.50 Client using the command line arguments. I would recommend using a Navision Client and opening the databases directly. Once they are reconnected, you can then use the 2.60 Client/Server again. Let us know if this solves your problem. Chris Krantz NCSD,NCSQL,MCSD,MCSE Microforum Inc. Toronto, Ontario, Canada

Heh heh, well, this is kinda embarassing, but I’m not running 2.60, OR 2.50. For reasons beyond my control, we’re running a 2.01b database with 2.01b clients. So, besides upgrading (which is impossible at this point), what are my other options?

This will work with 2.01b as well.

quote:


Originally posted by waverly: Anyone know where I can get a list of ALL the commandline arguments for fin.exe?


See Navision’s Installation and System Management manual, Section 4.1./System Setup/Overview of Program Properties Dave Studebaker das@libertyforever