How to zero all "water batch-number" thru counting?

Every time when we start to bake and create production orders AX create own water batch. Now we have about 600 batches. Once someone showed me how to zero all batches very fast, but I don’t remember how to do it and that person is working now in other place.

I presume this is from the batch number group on the item - why do you use it and what do you use it for? What do you mean by “zero all” is there a quantity on hand you want to remove or something else? It is not clear what it is doing, why it is doing it for you and what you want to do I am afraid.

The problem is that now we have water in our warehouse and water can’t be there. We have created in items all raw material(flour, water etc) for creating dough, every bun that we produce have also recipe. Flour, sugar, salt and other we have in our stock and we create PO for them, but not for water. This is why every time when we start producing raw maters go from stock. Because there is not water every batch go to negative amount and it looks that water is negative in stock.

Here is printsc

http://imageshack.us/f/805/batch.jpg/

http://imageshack.us/photo/my-images/11/counting.jpg/

. At this moment we tried to zero one batch at time in counting, but there is over 600 batches, it will take too much time.

Go to the quantity on hand screen and reset the quantity to zero.

Water should really be an item that is not stocked through the model group to prevent what you are seeing.

But there is 601 batches! And I need to reset every batch to zero?

Well you could run a stock count journal with no batch dimension and post zero.

When I try to post the journal without selecting any batch it say that it can’t post the journal. Please see the attached file.http://dynamicsuser.net/themes/hawaii/utility/http://img819.imageshack.us/img819/8127/waterbatch.jpg[/IMG] Uploaded with ImageShack.us:550:0]

Go to inventory in the journal line and reservation - then reserve lot option to associate all of the batches - then post the journal.

The reserve lot option is not activated. At this moment we have about -300 000 kg of water. When I try to put something in “Reservetion” AX says “Iventory dimension Warehouse is mandory and must consequently be specified”

So you have a negative position? And you have posted the negative position across multiple batches? The only way to get this to zero is to count by batch and enter 0 counted in every line. Reservation would work to reduce stock to zero, you need to increase it so there is nothing to reserve. Just hit 0 and down until you get to the last line then post it.

Yep, we have always a negative position for water. Sure, I can hit 0 for every batch, but when you have about 600 batches and it take about 4 hours until get to the last line you start to think, is there any way to merge all batches to one or something like this.

Why would it take 4 hours? pressing 0 and down takes a second, so 600 could be done in around 10 minutes, a pain but frankly the setup is wrong you should not be stocking water and why you would want to batch control it is another matter. As you have gone down this route you need to obey the controls of a batch controlled stocked item.

I don’t know why we are stocking water, our subsidiary use much easier way, they just add water (positive amount) thru counting to one batch. It took 4 hours maybe because our server is in other country, I’m not sure. Apparently It looks that there is no other way that just press 0 for every batch…

Or you write a modification to call the entry of the counted to 0. You should look at why you create new batches for water, it makes no sense at all!