Hotcopy problems

Hello everybody,

I’m having problems with restoring the backup created with Hotcopy.

My c/side database is 28 gb split in 4 files of 7 gb, when I copy the files to another fileserver (test) I can start Navision, but

in the database information screen the percentage used is on 100% in stead of 74% which I have on the production database.

Can someone please help me ??

Thanks in advance,


What version of Navision is this?

Try to expand the database by a small amount, make some write transaction, and see if the usage again climbs to 100%.

What are arguments for starting Navision Database Server?

And also what were arguments for hotcopy.exe?

Version is 3.60, when it’s at 100% I can’t even do a rename of the company.

At the moment I can’t try to expand the database because I did a restore to an empty database and I finally have a working database.

This will probably happen again. You need to either get the hot fix, or better still upgrade the executables to 3.70.

I have already used the HotCopy from Hotfix 28, but the result is the same.

Which executables do I need to upgrade to 3.70? Can I do that without changing to 3.70 completly?

We also tried to make a backup of the database to tape (with Veritas backup exec) and restore it to another server, but this results

in a corrupted database. The only method that works is a online Navision backup and restore.

You can have a Navision database with 3.60 objects and a client from 3.70 or newer version.
Have you tried to make a hotcopy in a test server with 3.70 client?

As I said, this is a KNOWN bug. To confirm this, you can try the following. You need to get a copy of the database that you can play with. Get this onto another machine, and open it with the 3.70B client, you will get a message askiing if you want to convert the database. Once converted, create a NAVISION BACKUP of thedatabase, and try to restore it with 3.70B. If this works, and the 100% used DB error goes away, then you are good to go.

Now you will need to do a technical upgrade, as described here : NAV Technical Upgrade By the way, this error is very rare, and in fact when I first got the error in the US, Navision US could not find any mention of it. I had them contact Navision UK, (where I had last reported it), and they found it.So be aware that if you contact Microsoft about it, they may not be able to help without doing a lot of searching. I have only seen the error in versions 2.00, 2.50 and 3.6.

Oh and if you can not recover the Database with 3.70B executables there is still a good chance that it can be recovered using C/DART.

Sorry onemore thing. If you are on support, then go for the latest executables that you have for your region, So 5.00 is possible, otherwise 4.00 SP3. Its the same amount of work to do a technical upgrade to any version up to 5.00. So you might as well do it.

I have a 3.70B client now, but when I try to open the database it comes with the following error,

“The server and client do not have the same program version number.”

Do I need to update the server as well ?