Form error

hi all,

when i click to open this Form and get this error message. i look and cant tell what is wrong with my Form.

Message (22:24:35)
Error executing code: Wrong argument type for function.

Stack trace


does anyone know what it is complaining about ? Thank you very much.


can u tell, regarding which form you are talking about.

Explain the name of the form, from where are you opening this form , either from AOT or from Main menu??

either from the AOT or Main Menu, when i click to run, it gives me the same error. let me know if you know what it is. Thanks so much.

Please disregard my post. i’ve figured the error out. Thank you all.

Hi all,

I have the same error and I have already compiled and compiled forward the classes mentioned in the stack trace, but it did not help.

SPN-AX, since you have figured the error out, can you please give me a hint how to solve it?

\Classes\SysSetupFormRun\run - line 4
\Classes\SysSetupFormRun\init - line 3

hello Mykola,

i am so sorry that i havent checked the forum for a while. The error that you are having is because: super() is called after your codes in your init() method.

put the super() method before your codes then you should be fine - like before your first " if " statement or something. Thats what i did with mine and it worked just fine. let me know if this fixed your issue.