fin.exe hangs on terminal server when accessing db

Hi all

I have a problem with clients running on a terminal server.
Sometimes the application hangs (forever or until I kill fin.exe).
When it hangs, fin.exe uses 25% of the cpu… constantly.
( I figure because the server is a quad-core hyperthreading, and fin.exe is only used by one core. Normally it would have gone to 100%)

It usually happens when I:

  • Hit Design on a table in the Object Designer.
  • Try to save the object (but only tables!)
  • Try to import objects
  • Try to import a backup

At night I have hotcopy running with DB-test, without any problems.

My installation details are:
Dynamics NAV 2009 - Native DB - Classic Client.
NAS running on same machine. (have tried disabling the NAS service - no effect).
Windows Server 2003 R2 - Service Pack 2
1 x Intel XEON CPU Quad Core 2GHZ
Database is placed on drive D which is placed on an underlying RAID.

There are no other visible problem, perfomance wise or on the disks. The server is simply flying.

Just have this strange problem… Maybe it has something to do with database access, but how??

There are no problems on the clients running on their individual PCs, connected to the same database server.

Any help would be appreciated.


Hi Soren,

It sounds like a permission problems to the system table Object (ID 2000000001). Check your permissions/securify filters. Create a simple form using the wizard and see it that can read it.

Hi Dave

Thanks for the reply.
I have tried that and it works fine.

When I say that the problem occurs when design tables, saving objects, it is not always the case.
But it occurs just about every second or third time I try to do it…

Hi Soren,

Does it only happen on terminal services or has it happens with a direct connection?

Hi Dave

It only occurs on the terminal server. And there are no other sessions on the terminal server, except for the Console session.
i was thinking that some other process on the server is interrupting the database access, but I have tried shutting down a lot of services with no result. :frowning:

I just tried to install SQLServer 2008 Express and the problem shows here too.

After creating the database on the SQL I begin to import my backup created with the native client.
When storing objects finsql.exe hangs, using full CPU.
I have full administrative rights on both windows and SQL.

I am lost…

Just a follow up…

Actually, the move to SQL may seem to have helped for now.
It will require some more testing, but I have not been able to produce the error today.

A colleague said that he had heard about issues with the native database and certain RAID configurations, and I think that could easily be the case here.
It all smells of some kind of I/O thing gone bad…

Anyway - problem has been worked around, for now.

I will post more in a week or so.

Thanks for all inputs.

Well… Bugger…

The problem is occurring again. Strangely it seemed to have vanished recently, just after a hardware change on the server.

I am beginning to think of IO problems…

Anyone? I am getting desperate…:frowning:

Hej Alexander,

I’m seeing the same problem. Did you ever find a solution?

Hi Erik

Unfortunately not.

In the meantime we moved the solution to another physical server, and here everything runs fine.

I still suspect it to have something to do with faulty hardware.