Fin.exe error when trying to restore a backup

Hello everyone, I am new to the forum so I hope I have posted this in the right spot.

I am trying to restore a backup of my 2.6 database and shortly after it starts to create keys I get a Microsoft fin.exe error. If I go back in and try to complete the restore it starts building the keys again and when it gets to the same spot I get the fin.exe error again. Any suggestions?

Can you give more detailed description of error? such as internal error number XX ?
The most comment error in restoring Db is having lack of DB in restore? Do you have enough space?

The error comes from Microsoft not Navision. It is the standard Windows error that says fin.exe has encountered a problem and needs to close. Please tell Microsoft about this problem …

I was originally running into a memory error but once I increased both the object cache and the DBMS cache that went away but I started getting this.

Are you restoring to database server or locally? Did you tried to restore locally if you are restoring in server? Can you tell memory option that you gave, Navision server cache is limited near 1G.

Okay here is the whole story. I am in the process of upgrading to 5.0. I have a new server that is running both 5.0 and 2.6. I took a file copy of my live 2.6, (which is on a different server), moved it into this new server, optimized the tables. Then I did a backup of the optimized database, created a new database on the new server, and tried to restore the backup in there. At first I was getting a Navision error saying “There is not sufficient memory to complete the task”. I then increased the object cache of the client to 100 MB and the DBMS cache on the client to 100 MB. Then I tried the restore again. This time when I restored into the new database, the backup got all the way to creating keys. It started creating the keys for the G/L Entry Table. When it started creating the Trans No. key it got about 50% done and then I got the fin.exe error. To restore locally, do you mean to run a stand alone version and try to restore into there?

Thanks for your time!


Restore database in your local workstation with Navision client. Copy restored db file to server and start server telling to use that database file.

So we found the solution (and part of the problem) and I thought I would post it for future reference. The solution was to restore the database using 5.0 executables. The problem seems to have been with the number of records in my G/L table (which is over 10000000). I don’t know what size 2.6 starts to have a problem with but I have another table with over 3000000 records and that one would restore just fine. Thank you for all your help.

Actually probably what your probelm was was the temp file. In 2.60 keys are sortedin one huge chunck in the database, and a temp file is used for this. If you run out of space for that file, you would get an OS error. ANd its not really the number of records, its the actual size of the key that matters. still using the 5.00 exe is a good solution.

And thanks for letting us know how you solved the issue. Allways good to help out the next person.