Files with this file type cannot be attached error message

HI -

Has anyone encountered error “files with this file type cannot be attached” when trying to add a file to a record? It seems to be happening inconsistently (but much more often than not) adding to sales orders and purchase orders. We’re adding pdfs and Excel files, and I’ve verified the extensions are supported in document management parameters and the file size doesn’t exceed the max. It happens after New → File → Browse → navigate to and select the file, instead of attaching the error is thrown. Usually, out of maybe ten attempts with the same file, one is successful, although occasionally it will go through on the first try. For some people, using image as the document type as worked, but not for everyone. I’ve also tried getting rid of personalizations and usage data just in case, but no luck.

Does anyone know a fix or have some ideas? Thanks!

Which version of AX it is? Please always attach a version tag (e.g. AX 2012), to let us know which version is the thread about.

D365, 10.0.8

We ran into the same thing.