Exchange rate expiration

I am tying to set a currency exchange rate but am encountering this problem,

Cannot edit a record in Exchange rate (ExchangeRate). The ‘Expiration’ value needs to be greater than or equal to the ‘Start date’ value.

Can someone please help?

I have another issue related to the above post… I think this is the root cause for the previous post!

I tried tyo create a Fiscal calender and it just doesnt allow me to change the dates…

4341.fy 2012.png

Check your AX license - I think it expired.

Hello Chitanya,

I would like to know whether the issue " Exchange rate expiration" get resolved or not.

I am also facing the same issue.

I have tried it on old and new fiscal year as well. and checked License file is not expired.

I think it is related to AOS leve autorisation,Validfrom and ValidTo columns .

I have created new exchange rate for diffrent periods but it seems system not featching few record which are available in table. the same record i am able to fetch in SQL using query.

Thanks,

Nitin