Excel Leading Zeros....again

Is there anyway to tell Excel using automation that a certain cell or range of cells should be formated as Text only, not as a number? I know that I can put a character in front of the leading zeros to retain them but it seems kind of hokey. [V] If that can’t be done, can anyone tell me how to create a macro in Excel and cause it to run using automation?

Daniel Rimmelzwaan provided me with this solution and it works great: xlSheet.Range(‘C1’).NumberFormat := ‘@’;

try it by putting comma before value. e. g. XlWorkSheet.Range(‘B’ + xlRowID).Value := ‘’’’ + FORMAT(Employee.“No.”); It will work. Only thing it will so warning in excel that you can disable through options. Regards, Param