error while saving gantt production schedule in nav2009 clasic client

In the classic client on version NAV2009R2 i could run and edit the gantt production shedule in the Cronus database. But when i was trying to save a production shedule (to xml-file) i had this error message:

Could not create an instance of the OLE control or Automation server identified by GUID={F5078F18-C551-11D3-89B9-0000F81FE221}6.0:{88D969C0-F192-11D4-A65F-0040963251E5}:‘Microsoft XML,v6.0’.DOMDocument40. Check that the OLE control or Automation server is correctly installed and registered.

Because this took me too long to solve this issue (and because i want to have i least one hit next time i’ll google my error message[:)]) i will tell how i solvedthis:

On the internet i found some suggestions, but without any result:

  • reinstall msxml 6.0
  • register all relevant ocx’s and dll’s
  • checking clsid’s in registry,…

Then i tried to check if my MSXML worked fine. So i’ll tried to run xml-port 5500 from a different codeunit wich worked fine…

I checked the variables of codeunit 5500 and found a little bug. In the global variables i saw a variable calling xml version 6 and DOM version 6:

  • OutboundXML - Automation - ‘Microsoft XML, v6.0’.DOMDocument60

But when saving my xml file the version of DOM used was 4… After checking all local variables I’ve found in de OnCommit-trigger of ProdShed:

  • ProdSched::OnCommit(VAR InitialDataSetDOM60 : Automation “’’.IDISPATCH”;VAR SimulatedChangesDOM60 : Automation “’’.IDISPATCH”;VAR Confl

That 3 varables were wrongly defined:

  • InitialDataSetXML - Automation - ‘Microsoft XML, v6.0’.DOMDocument40
  • SimulatedChangesXML - Automation - ‘Microsoft XML, v6.0’.DOMDocument40
  • ConflictingChangesXML - Automation - ‘Microsoft XML, v6.0’.DOMDocument40

Changing that to ‘Microsoft XML, v6.0’.DOMDocument60 solved the problem!


I have the same problem, and I wanted to try out your solution.

But when I change ‘Microsoft XML, v6.0’.DOMDocument40’ to ‘Microsoft XML, v6.0’.DOMDocument60’ and want to save it, I get the next error message:
Could not load the selected type library.

Do you have any idea what can be the problem? Maybe you had the same?

Thanks a lot, Frida


I am facing the same issue. I also could not resolve by the above suggestion. What should be missing in my case ?