Error while opening Report"object reference not set to an instance of an object"

Hi friends

i added a text field in ledgerjournaltable.

while opening the report i am getting the error like this "object reference not set to an instance of an object"

DIPL123.PNG

Hi Anil,
Report name…?,AX version…?

Hi,
Try Full CIL Compilation…

AP<<Journals<<InvoiceJournal and lines print journal
AX 2012 r3

Hi,

This may helpful to you…

https://hellodax.com/2015/02/15/error-object-reference-not-set-to-an-instance-of-an-object-when-open-ssrs-report/

hi

now report is open…but field was not displaying in report

Hi,
Have u tried all the scenarios…

First check whether the added field is there in report design.
If it’s there then do Clean User Usage data on Tools-> Option → Usages Data.
4. Restarting reporting services.
5. Refresh all cache on AOT, on AOT-> Tools → Caches
5. Re-Deploy the SSRS report.
6. Restarting AOS. << sometimes it works like magic -_-“
If it’s not , add the field again and do same.
If data is not coming do debugging.

Generally …Deploying the report & refreshing report server cache is enough.

Hi Anil,

Good day!

Please follow this procedure below. I’ve already encountered that issue.

  1. First open MS Dynamics
    2.Then Press CTRL + D. AOT Window will open.
    3.Then on menu bar upper window click “Tools” then select “Catches”
  2. Click the three submenus of “Caches” the “Refresh Data”,“Refresh Elements” and “Refresh Report Data”
  3. After you click the caches submenus try to generate report again.

Hope this procedure help you

Hi portia2017/Krishna Rao/Gopinath

Issue has been solved. thanks for reply