Error when printing Sales Invoice Proforma - Normal Sales Invoice is working correctly


we are using Dynamics AX 4.0.

Since two weeks we have a weird issue.
Some AX users can´t print proforma invoices.

When such a user tries to print a proforma invoice, then the report gets shown correctly.
If you click on the print button in the report view and choose a print (or print to file etc.) the following message is shown:

The message translated to:

A record in Print Job information (job-level) (PrintJobHeader) could not be altered.

If you dismiss this message the print job is sent to the print, but the pages are completely empty.
A new user also has the problem and my Admin-Account also has this problem (confirmed working 1 month ago).

The same users can print normal Sales Invoices.
Even if I alter an Invoice (set Proforma = true), the report can be printed correctly.

Any suggestions?
I checked everything, but I cant find the error.

Our dev and test-system are showing the same error, so it cant be AOS related.
We also restartet the AOS and DB multiple times


Have you tried to debug and check why it updating PrintJobHeader? (I don’t have AX4 to check)

I dont know where to check for such an update.
Even the PrintJobHeader Table is not accessible within AX (only from the SQL Server).

I also tried to reset the SalesInvoice report to its stock code (by deleting the changes in VAR and USR layer), but the error still occurs.

It is a system table, you will see it under system documentation node in AOT. Look at the cross references of that, so see where it is been updated, so that you can debug the process.
have you setup to save the report in print archive?

I set a breakpoint in every function in which the PrintJobHeader is referenced.
The only point where a breakpoint is hit while printing (event by the working reports) is:

So that is not leading to an answer.

For the print archive:
I dont know if this is configured. I have taken over this AX about 2 years ago.
Where can I see if this is configured?

I just checked the print archive.
I dont have the option to print to archive while printing a report and my print archive is completely empty.
So I assume the archive is disabled.

Check if there is any customized code. Update the cross references again and check.