Error when importing translated captions

I have been translating our application (based on the translate export) and when ready wanted to import (using translate>import) it into our application objects again. For the majority of the objects this worked OK, but for a small subset (~20 objects) I am getting the following error:


The following SQL Server error or errors occurred when accessing the Company Information table:

297,“42000”,[Microsoft][ODBC SQL Server Driver][SQL Server]The user does not have permission to perform this action.

SQL:

{CALL [sp_rename](?, ?, ?)}


Searching for posts on sp_rename brought me to this one:

BUG Renaming fields fails at SQL “named instances”

It doesn’t however help (whilst it’s claiming that a similar issue should have been fixed in later NAV builds). On mibuso I did not succeed in finding any posts.

Anybody a clue on how to solve this?

One funny phenomenon was that with some objects this error occured the first time I tried to import, but when retrying (2nd, 3rd, … time) it worked.

The system I am running on is:

  • Windows Server 2003 R2 SP2
  • NAV 2009 SP1

(haven’t got more details on it at hand)

It after all seemed only to be a SQL Server rights matter.

Hi Luc,

As we discussed, the solution was in the SQL DB security. I posted it in my blog