Error in Databasestructure

Hi all! - I have a backup (FBK) of a native database, version 3.70 PL - I create a new database (Server 2003, english version) also using the 3.70PL client - I import the FBK to this database So far, so good - I can use the database as ususal … … but if I try to create a backup (FBK) from this local/new database an error occurs instantly:


There is an error in the database structure. The error (1190 in module 19) may have been caused by the computer or a program. …

The same error occurs when I run a database check. Of course, the original DB (where the first backup was from) has no error and in Poland there are no problems with Backup/Restore. Could anybody tell me WHY this happens and WHAT I could do to solve this? Thanx & best regards, Jörg

I think You have different code pages on the computers. Poland has some strange characters that would be difficult to restore in a system with an english character set (or any other language) //Lars

As Lars stated it’s probably a strange character. A search of the forum for “1190 19” you will find a few posts on this subject. tick the Search For All Words

Hi! Thanx for your replies! If I don’t err, the error means 19-1190 #Err_DB_AlphaTypeIncorrect DB_Err(1190) a wrong charachter in a Code-field; and a possible solution could be to export the data to file, delete the records and re-import the data. I can imagine, that this would cause a conversion of the “fancy” polish characters to the local codepage. So I have tried this with the first table (15), then the error occurs on the next table (18). Obviously this error is “included” into any table tha has a code-type (Key-)field(!?), and it would cause a hell of work and time to export/Re-import all the data of all tables [V] Or could you suggest another - easier - way?

I’m no code page expert, but I thought I read someplace that you must be careful when importing a database backup to use the same codepage as the machine that made the backup. You indicated that you used the PL client to do the restore, but do not indicate whether you changed your machine’s locale (Control Panel, Regional and Language Options, Advanced, Language for non-Unicode Programs) to whatever the backup machine was set to prior to doing the restore. Hope this helps, and please accept my apologies if I’ve got it wrong.


Control Panel, Regional and Language Options, Advanced, Language for non-Unicode Programs

Good idea, I will try that …